Bug 764869 - (GLUSTER-3137) Filesystem - Not mounting on client
Filesystem - Not mounting on client
Status: CLOSED DUPLICATE of bug 764871
Product: GlusterFS
Classification: Community
Component: transport (Show other bugs)
3.2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-06 09:48 EDT by Dheeraj
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dheeraj 2011-07-06 09:48:06 EDT
I have instaleld GlusterFS-3.2 on CentOS-5.5  
I have mounted it on CentOS-5.4 ,both  having 2.6.18 kernel. 

Now I need to mount it on a 2.6.32 kernelie FC12.
I have installed the three rpms. core,fuse and rdma. 
I used the client.vol file from server and tried mounting.
Its showing mounted on mount command.
But in df -h its gives the below given error

df: `/home': Transport endpoint is not connected

OFED-1.5.1 is the ofed version installed.

In /var/log/glusterfs/ I m getting the below given error:

[2011-07-06 19:31:10.567454] E [rdma.c:3414:rdma_handle_failed_send_completion] 0-rpc-transport/rdma: send work request on `mthca1' returned error wc.status = 12, wc.vendor_err = 129, post->buf = 0x32ba000, wc.byte_len = 0, post->reused = 4388
[2011-07-06 19:31:10.567513] E [rdma.c:3422:rdma_handle_failed_send_completion] 0-rdma: connection between client and server not working. check by running 'ibv_srq_pingpong'. also make sure subnet manager is running (eg: 'opensm'), or check if rdma port is valid (or active) by running 'ibv_devinfo'. contact Gluster Support Team if the problem persists.
[2011-07-06 19:31:10.567953] E [rpc-clnt.c:338:saved_frames_unwind] (-->/opt/glusterfs/3.2.0/lib64/libgfrpc.so.0(rpc_clnt_notify+0xb9) [0x7fc383f9e5f9] (-->/opt/glusterfs/3.2.0/lib64/libgfrpc.so.0(rpc_clnt_connection_cleanup+0x7e) [0x7fc383f9dd9e] (-->/opt/glusterfs/3.2.0/lib64/libgfrpc.so.0(saved_frames_destroy+0xe) [0x7fc383f9dd0e]))) 0-crlgfs1-client-0: forced unwinding frame type(GF-DUMP) op(DUMP(1)) called at 2011-07-06 19:31:09.552278
[2011-07-06 19:31:10.567984] W [client-handshake.c:1242:client_dump_version_cbk] 0-crlgfs1-client-0: received RPC status error
[2011-07-06 19:31:10.568006] I [client.c:1883:client_rpc_notify] 0-crlgfs1-client-0: disconnected

Hope there is some solution for this. 
All ib command is working fine.
Comment 1 Raghavendra G 2011-07-06 23:38:05 EDT

*** This bug has been marked as a duplicate of bug 3139 ***

Note You need to log in before you can comment on or make changes to this bug.