Bug 76490 - wacom graphire 2 tablet not supported properly (scroll/pen/etc)
wacom graphire 2 tablet not supported properly (scroll/pen/etc)
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 09:11 EDT by Need Real Name
Modified: 2014-03-16 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 15:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-22 09:11:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017

Description of problem:
Kudzu/installer fails to configure the graphire 2 tablet properly.  It sets up a
mouse configuration for it in XF86Config in which the scroll wheel is reversed
(I *believe* this might be a kernel module bug for the wacom driver), and the
pen/eraser are not supported.

The tablet was configured as a mouse device, even though the "wacom" driver is
the appropriate one.  In addition, the ZAxisMapping needs to be "5 4" instead of
"4 5" to work around the aforementioned kernel bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install wacom tablet
2.  Start X
3.  Start GIMP and try to use the pen/eraser (input device dialog)
	

Actual Results:  No devices displayed

Expected Results:  Pen/Cursor/Eraser devices displayed

Additional info:

This is the output from USBVIEW.  Let me know if you need more info.

ET-0405A-UV2.0-3
Manufacturer: WACOM
Speed: 1.5Mb/s (low)
USB Version:  1.10
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 8
Number of Configurations: 1
Vendor Id: 056a
Product Id: 0011
Revision Number:  2.03

Config Number: 1
	Number of Interfaces: 1
	Attributes: 80
	MaxPower Needed:  40mA

	Interface Number: 0
		Name: wacom
		Alternate Number: 0
		Class: 03(HID  ) 
		Sub Class: 1
		Protocol: 2
		Number of Endpoints: 1

			Endpoint Address: 81
			Direction: in
			Attribute: 3
			Type: Int.
			Max Packet Size: 8
			Interval: 10ms
Comment 1 Bill Nottingham 2005-09-23 15:37:07 EDT
Apologies for the lack of response. Currently, configuration of tablets,
scrollpads, etc, is done via rhpl and system-config-xfree86, both of which have
gone undergone major revisions since this was filed (as has the input subsystem
the drivers work under.)

Please try with a later release, such as RHEL 4, Fedora Core 3 or Fedora Core 4,
and open a new issue if this problem perists.

Note You need to log in before you can comment on or make changes to this bug.