Bug 76496 - console window does not show Segmentation fault
console window does not show Segmentation fault
Status: CLOSED NOTABUG
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
Tom Tromey
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 10:56 EDT by Need Real Name
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 14:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-22 10:56:41 EDT
Description of Problem:
If I run/debug a program that I know results in a segmentation fault, the
console window does not show it. It just shows the program to have terminated.
When the same program is run on command line, it will output "Segmentation
Fault" and then terminate.

Version-Release number of selected component (if applicable):

snapshot-20021020-eclipse-linux-gtk-2.0.1-9.i386.rpm
and the most recent cdt build on eclipse.org

How Reproducible:
always

Steps to Reproduce:
1. build a file that has a segmentation fault	
2. run the program -> terminates without any output 	
3. debug the program-> run to completion -> console view still doesn't show
Segmentation Fault, but the console view header does. 

Actual Results:


Expected Results:
should show "Segmentation Fault" in console.

Additional Information:
Comment 1 Jeremy Handcock 2003-09-11 14:56:37 EDT
This is behavior by design.  See
https://bugs.eclipse.org/bugs/show_bug.cgi?id=26048.  Closing.
Comment 2 David Lawrence 2003-12-11 14:28:39 EST
Changing product to RHEL.

Note You need to log in before you can comment on or make changes to this bug.