Bug 76497 - Tclx shared object cannot be loaded with /usr/bin/wish
Tclx shared object cannot be loaded with /usr/bin/wish
Status: CLOSED DUPLICATE of bug 54433
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 10:59 EDT by Bernhard Ege
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 11:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Ege 2002-10-22 10:59:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
When trying to include the shared object, tclx, in wish, one is met with this error:
couldn't load file "/usr/lib/tclX8.3/../libtclx8.3.so":
/usr/lib/tclX8.3/../libtclx8.3.so: cannot open shared object file: No such file
or directory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start wish: $ wish
2. enter command: % package require Tclx
3. observe error

Actual Results:  couldn't load file "/usr/lib/tclX8.3/../libtclx8.3.so":
/usr/lib/tclX8.3/../libtclx8.3.so: cannot open shared object file: No such file
or directory

Expected Results:  libtclx.so should have been loaded silently. libtclx8.3.so
does not exist.

Additional info:

Creating a link libtclx8.3.so in /usr/lib that points to libtclx.so resolves the
problem, allowing wish to load the Tclx object.
Comment 1 Jens Petersen 2002-11-11 00:44:06 EST

*** This bug has been marked as a duplicate of 54433 ***

Note You need to log in before you can comment on or make changes to this bug.