Bug 765007 - (GLUSTER-3275) glusterd should remove 'volume-id' after a remove-brick and delete volume.
glusterd should remove 'volume-id' after a remove-brick and delete volume.
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 03:28 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2011-07-29 03:28:24 EDT
With the 'volume-id' extended attribute 'lingering' on bricks that were part of a gluster volume, adding them to a new volume becomes a hindrance. User needs to remove the 'volume-id' extended attribute before (s)he could (re)use the brick in another volume. 'volume-id' is intended to be an internal mechanism by which we prevent a brick from being used in two volumes at the same time. The user must not be made 'aware' of it.
Comment 1 Amar Tumballi 2011-07-29 04:42:10 EDT
We have bought in 'volume-id' extended attribute to prevent re-using of the export bricks from one volume to other. We just need to document the way how it can be reused if that is the intention.

bash# setfattr -x trusted.glusterfs.volume-id <BRICK-PATH> 

With the above command, one can make the brick-path re-exportable again.

Note You need to log in before you can comment on or make changes to this bug.