Bug 765051 - (GLUSTER-3319) Use librdmacm for connection establishment.
Use librdmacm for connection establishment.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rdma (Show other bugs)
mainline
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Raghavendra G
: FutureFeature
: GLUSTER-3139 (view as bug list)
Depends On:
Blocks: 856987 952693 962431
  Show dependency treegraph
 
Reported: 2011-08-03 07:25 EDT by Raghavendra G
Modified: 2014-04-17 09:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2011-08-03 07:25:55 EDT
gluster currently uses tcp/ip based communication channel with gluster specific protocol to exchange infiniband addresses. However librdmacm gives the same functionality and its a standard protocol used for connection establishment.
Comment 1 Raghavendra G 2011-09-21 21:54:38 EDT
*** Bug 3139 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2011-11-24 00:38:24 EST
CHANGE: http://review.gluster.com/148 (Change-Id: I251be23d2c60b88589f71e7a8c3b1f2b7e3eb3e6) merged in master by Anand Avati (avati@gluster.com)
Comment 3 Amar Tumballi 2012-02-27 05:35:54 EST
This is the priority for immediate future (before 3.3.0 GA release). Will bump the priority up once we take RDMA related tasks.
Comment 4 Amar Tumballi 2012-10-11 05:51:17 EDT
http://review.gluster.org/149 and http://review.gluster.org/4044 (good to have)

Tested on 2x2 dist-replica volume on 4 servers and 2 clients.

mount/umount in a loop.
Comment 5 Vijay Bellur 2012-10-11 19:36:02 EDT
CHANGE: http://review.gluster.org/4044 (client-handshake: synchronize config.remote_port setting b/w rpc_clnt_reconnect and client_query_portmap_cbk) merged in master by Anand Avati (avati@redhat.com)
Comment 6 Amar Tumballi 2012-12-21 06:14:15 EST
*** Bug 764871 has been marked as a duplicate of this bug. ***
Comment 7 Anand Avati 2013-05-07 06:56:00 EDT
REVIEW: http://review.gluster.org/149 (rpc-transport/rdma: use rdma-cm for connection establishment.) posted (#19) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 8 Anand Avati 2013-05-13 06:45:18 EDT
REVIEW: http://review.gluster.org/4378 (rpc-transport/rdma: reap async events in a dedicated thread.) posted (#5) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 9 Anand Avati 2013-05-13 06:46:54 EDT
REVIEW: http://review.gluster.org/149 (rpc-transport/rdma: use rdma-cm for connection establishment.) posted (#20) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 10 Anand Avati 2013-05-17 03:19:10 EDT
COMMIT: http://review.gluster.org/149 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 05d2d4a401cb2497185b091e666638e01f1d7f1d
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Tue Dec 18 12:47:43 2012 +0530

    rpc-transport/rdma: use rdma-cm for connection establishment.
    
    Till now gluster used tcp/ip based communication channel with
    gluster specific protocol to exchange infiniband addresses.
    
    Change-Id: I9de4db398a0e2af51d3d2d68c2fe42168102b190
    BUG: 765051
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Reviewed-on: http://review.gluster.org/149
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 11 Anand Avati 2013-05-17 03:19:40 EDT
COMMIT: http://review.gluster.org/4378 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 714a2037e96f24d49ac1028bc953bd39ae0363b4
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Mon Jan 7 11:05:39 2013 +0530

    rpc-transport/rdma: reap async events in a dedicated thread.
    
    * Also sets srq_limit of srq to 10, so that we'll receive an event
      when we are about to empty the receive buffer list.
    
    BUG: 765051
    Change-Id: I5436166ea21fc963ee15088fc2df743ec4b96ba7
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Reviewed-on: http://review.gluster.org/4378
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 12 Anand Avati 2013-05-27 04:32:14 EDT
REVIEW: http://review.gluster.org/5096 (rpc-transport/rdma: use rdma-cm for connection establishment.) posted (#1) for review on release-3.4 by Raghavendra G (raghavendra@gluster.com)
Comment 13 Anand Avati 2013-05-27 04:32:38 EDT
REVIEW: http://review.gluster.org/5097 (rpc-transport/rdma: reap async events in a dedicated thread.) posted (#1) for review on release-3.4 by Raghavendra G (raghavendra@gluster.com)
Comment 14 Anand Avati 2013-05-27 14:01:39 EDT
COMMIT: http://review.gluster.org/5096 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 536f6ac4f12ffa59bf0412d93538d80eb3bdd02a
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Tue Dec 18 12:47:43 2012 +0530

    rpc-transport/rdma: use rdma-cm for connection establishment.
    
    Till now gluster used tcp/ip based communication channel with
    gluster specific protocol to exchange infiniband addresses.
    
    Change-Id: I9de4db398a0e2af51d3d2d68c2fe42168102b190
    BUG: 765051
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Reviewed-on: http://review.gluster.org/149
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/5096
Comment 15 Anand Avati 2013-05-27 14:02:09 EDT
COMMIT: http://review.gluster.org/5097 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit e617990a87dbfa78bb625e490d6eac8e967419fd
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Mon Jan 7 11:05:39 2013 +0530

    rpc-transport/rdma: reap async events in a dedicated thread.
    
    * Also sets srq_limit of srq to 10, so that we'll receive an event
      when we are about to empty the receive buffer list.
    
    BUG: 765051
    Change-Id: I5436166ea21fc963ee15088fc2df743ec4b96ba7
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Reviewed-on: http://review.gluster.org/4378
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/5097
Comment 16 Niels de Vos 2014-04-17 09:12:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.