This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 76516 - Onboard network (BCM4401) and sound fails on Asus A7V8X
Onboard network (BCM4401) and sound fails on Asus A7V8X
Status: CLOSED DUPLICATE of bug 80545
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 14:46 EDT by Toralf
Modified: 2013-07-02 22:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/hwconf (2.63 KB, text/plain)
2002-10-24 07:50 EDT, Toralf
no flags Details

  None (edit)
Description Toralf 2002-10-22 14:46:23 EDT
Description of Problem:
I'm trying to install across the network on a machine with a brand-new Asus
A7V8X motherboard using its onboard network, which is based on the Broadcom
BCM4401 LAN controller. I've not been able to set up the actual network yet.


Version-Release number of selected component (if applicable):


How Reproducible:
Every time

Steps to Reproduce:
You know the drill


Actual Results:
After specifying installation source (FTP in my case), I'm asked to specify a
network driver. No matter what I specify, installer will return to previous
screen after a short while. Ctrl+Alt+F3 screen reports insmod failure.


Expected Results:
Network installation starts.

Additional Information:
OK, I haven't tried *all* drivers supplied, but I've tested a decent number -
including various modules on the "Supplimentary Network Drivers" floppy. In
particular, note that both Broadcom drivers included fail to load.
Comment 1 Michael Fulbright 2002-10-23 11:49:34 EDT
I would recommend trying the new Red Hat Linux 8.0 release. It has more driver
support.
Comment 2 Toralf 2002-10-24 07:50:05 EDT
I can't switch to Red Hat 8.0 just like that as there are major differences from
7.3 (notably, the upgrade to GNOME 2.0.) We need to test all applications, and
possibly port some of customisations and utilities first.

Anyhow, I've now installed using a PCI network card, then upgraded to
kernel-2.4.18-17.7.x from Red Hat 7.3 updates, which I assume is identical to
the 8.0 version. I still can't find a driver for the onboard network, though; it
is at least not auto detected.

I will attach /etc/sysconfig/hwconf, which perhaps says a bit more about what is
going on.
Comment 3 Toralf 2002-10-24 07:50:53 EDT
Created attachment 81904 [details]
/etc/sysconfig/hwconf
Comment 4 Toralf 2002-10-24 08:54:38 EDT
I'm also having problems with the on-board sound controller on this machine. The
harware detection output seems sensible, see attached hwconf, but module
installation fails with message:

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: init_module:
No such device
/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: insmod
/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o failed
/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: insmod
via82cxxx_audio failed

BTW, should we change component from "installer" to "kernel" and reassign bug
accordingly?



Comment 5 Toralf 2002-10-24 08:58:37 EDT
Oh, and while I'm at it: I also got agpgart failure initially.

options agpgarg agp_try_unsupported=1

in /etc/modules.conf helped.
Comment 6 Jeff Garzik 2002-10-25 13:36:54 EDT
There is no known driver for this on-board BroadCom ethernet.
The on-board sound is not yet supported either :(
Comment 7 Jeff Garzik 2002-10-25 13:37:40 EDT

*** This bug has been marked as a duplicate of 54905 ***
Comment 8 Giacomo Magnini 2002-12-14 03:37:56 EST
A small note for everyone: the linux driver for the BroadCom integrated
controller IS available on the support CD that Asus ships with the card, or at
least on the recent CDs they ship. I have it on my A7V333-X installation CD.
It's upto version 1.0.1 and it contains a GPL2 license.
The sound chip has only an ALSA driver (available on the Realtek site), and with
the old sound system it doesn't work: a via 82cxxx chip is detected but you
can't configure and use it.
Now, the big question is: since the BroadCom driver is GPLed, would it be
possible to distribute it with a distribution or be integrated with the
mainstream kernel?
Any feedback would be appreciated.
Comment 9 Toralf 2002-12-16 03:06:26 EST
I feel really stupid now, as I never really checked the CD - I just just spent a
lot of time searching the Net for a driver or info on the chip, but found
nothing except for a few broken download links (not referring to any particular
OS) on the Asus web site.

Anyhow, I can confirm that there is a working driver, included in source code
form. There's supposed to be an RPM, too, but I can't find it anywhere, so I
made one myself - see ftp://www.procaptura.com/pub/SPRMS/bcm4400-1.0.1-0pcap.src.rpm
Comment 10 Toralf 2002-12-16 03:12:11 EST
Minor slip, there. Correct URL is

ftp://ftp.procaptura.com/pub/SRPMS/bcm4400-1.0.1-0pcap.src.rpm
Comment 11 M.Faulhammer 2002-12-20 07:04:48 EST
Hi all,
for sure you can get the Linux driver for Broadcom 4401
seee
http://www.asus.com.tw/support/download/selectftp.aspx?l1_id=1&l2_id=10&l3_id=18&m_id=2&f_name=4401_653.zip~zaqwedc

There is only a tar file and you have to compile it by your own.
I got a problem with that in RedHat 8.0, because the new version of the gcc
Compiler abortet with a lot of errors (I am too newbie to fix it).
But I compiled it succesfully with RedHat 7.2 (gcc-2-96?) on my business pc.

I´ll try the rpm version from toralf@kscanners.com. 
Thank you.
Comment 12 Jeff Garzik 2002-12-23 12:26:50 EST
The BroadCom driver is unacceptable for many reasons, unfortunately.

Red Hat is developing a driver called "b44" which will soon be available for
use, and that is what we will integrate into our kernel.
Comment 13 Petr Suchomel 2002-12-27 12:35:34 EST
When are you going to merge new drivers into distro? I tested new A7V8X MB with
Rh8.0 and Phoebe, but neither onboard network controler Broadcom 5702
(1000Mbits) nor integrated sound card works.
Comment 14 Toralf 2003-01-02 07:12:53 EST
Would it be too much to ask to have the updated kernel package obsolete
"bcm4400" (which is the name of my RPM for the Broadcom driver, and supposedly
the official one from Broadcom, too)?
Comment 15 Jeff Garzik 2003-01-30 16:09:51 EST

*** This bug has been marked as a duplicate of 80545 ***
Comment 16 Red Hat Bugzilla 2006-02-21 13:50:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.