Bug 76520 - Several quirks with XFree86-4.2.99.1-0.20021018.5
Several quirks with XFree86-4.2.99.1-0.20021018.5
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 15:26 EDT by Justin Georgeson
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 15:33:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspvi -vn (2.48 KB, text/plain)
2002-10-22 15:31 EDT, Justin Georgeson
no flags Details
/etc/X11/XF86Config (1.95 KB, patch)
2002-10-22 15:32 EDT, Justin Georgeson
no flags Details | Diff
/var/log/XFree86.0.log (50.34 KB, text/plain)
2002-10-22 15:33 EDT, Justin Georgeson
no flags Details

  None (edit)
Description Justin Georgeson 2002-10-22 15:26:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
1) I had to disable dpms in the monitor section of /etc/X11/XF86Config in order
to get 16 and 24 bit color.

2) If I log in as a normal (not root) user account, I have the black 'X' cursor
permanently drawn in the center of the screen. I also have the fully functional
red transparent cursor, but that black X just sits there. Once it was in the
upper-left corner of the screen. BTW - how do I make the cursor go back to the
normal color, I don't like the red. (the transparency is fine, I just don't like
it being red)

3) Unless logged in as root, the battstat-applet (laptop bettery meter for gnome
panel) is problematic. At first it would crash the panel if I tried to load it.
Now it sometimes loads, usually isn't remembered between sessions, sometimes is
remembers but crashes when I start a session, and sometimes a session starts
with multipl instances. This isn't very predictable in terms of how it will
behave, but predictable that it won't be behaving as expected. (If the applet
loads, it runs fine, it's just a question of if it will load)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
2) log in as my normal user account and run startx. 


Actual Results:  2) the black 'X' which is the [moveable] mouse cursor until
GNOME/metacity have loaded is drawn permanently in the center of the screen once
GNOME/metacity. The red transparent mouse cursor is drawn and totally functional
at this point, but the black X is still there.


Expected Results:  2) The black 'X' should turn into the red transparent cursor
once GNOME/metacity load.


Additional info:

Since the battstat-applet behavior isn't predictable, I tried to put all
relevant info in the description, as Actual Results vary.
Comment 1 Justin Georgeson 2002-10-22 15:31:12 EDT
Created attachment 81644 [details]
lspvi -vn
Comment 2 Justin Georgeson 2002-10-22 15:32:31 EDT
Created attachment 81645 [details]
/etc/X11/XF86Config
Comment 3 Justin Georgeson 2002-10-22 15:33:17 EDT
Created attachment 81646 [details]
/var/log/XFree86.0.log
Comment 4 Mike A. Harris 2002-10-22 19:18:17 EDT
When reporting multiple bugs, problems or requests for enhancement
in Red Hat bugzilla, you _must_ report one and only one single issue
per bug report.  Otherwise there is no way for us to properly track
each issue in the database, and close them when they are resolved.

Please open new bug reports for each of the issues you would like
tracked.

Note You need to log in before you can comment on or make changes to this bug.