Bug 765240 - (GLUSTER-3508) [e795fcf2895496ad5412bfd4ac50a358567ecabb]:mount hangs if mount from a non-trusted machine is issued.
[e795fcf2895496ad5412bfd4ac50a358567ecabb]:mount hangs if mount from a non-tr...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Kaushal
Shwetha Panduranga
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-09-05 04:26 EDT by Rahul C S
Modified: 2013-07-24 13:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:48:18 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2011-09-05 04:26:27 EDT
1. Create a volume & start it & also set auth.allow to a host. 
2. From a different host, mounting the volume succeeds, with exit status 0, but actually it would have failed since log files say set volume unsuccessful(authentication failure)
3. accessing the mount will make the terminal hang forever & also will df -h.
4. Unmounting the volume does not kill the process also. 

We could introduce something like in nfs where it shows a EPERM error which could be helpful.

User also reported this issue in:
http://community.gluster.org/q/re-how-to-restrict-access-to-glusterfs-native-clients-by-ip-address/

Happens on all branches.
Comment 1 Anand Avati 2012-02-03 10:41:57 EST
CHANGE: http://review.gluster.com/398 (protocol/client : prevent client from reconnecting when server authentication fails) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Shwetha Panduranga 2012-05-29 03:23:26 EDT
Verified the bug on 3.3.0qa43. Bug is fixed. 

Output:-
---------
[05/29/12 - 18:17:55 root@APP-SERVER1 ~]# gluster v info
 
Volume Name: dstore
Type: Replicate
Volume ID: b28affad-17bc-4f2f-90a4-a94eef7a93ac
Status: Started
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Bricks:
Brick1: 192.168.2.35:/export_sdb/dir1
Brick2: 192.168.2.36:/export_sdb/dir1
Brick3: 192.168.2.35:/export_sdc/dir1
Options Reconfigured:
auth.allow: 192.168.2.34
cluster.self-heal-daemon: off
diagnostics.client-log-level: DEBUG
diagnostics.brick-log-level: DEBUG
performance.stat-prefetch: off


[05/29/12 - 12:53:42 root@Shwetha-Laptop ~]# mount -t glusterfs 192.168.2.35:/dstore /mnt/gfsc1
Mount failed. Please check the log file for more details.

[05/29/12 - 12:53:52 root@Shwetha-Laptop ~]# echo $?
1

[05/29/12 - 12:53:55 root@Shwetha-Laptop ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr C0:CB:38:4B:7C:54  
          inet addr:192.168.1.124  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c2cb:38ff:fe4b:7c54/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:74298 errors:0 dropped:0 overruns:0 frame:154531
          TX packets:24279 errors:6 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8923324 (8.5 MiB)  TX bytes:2918758 (2.7 MiB)
          Interrupt:17

Note You need to log in before you can comment on or make changes to this bug.