Bug 76529 - gnome-terminal option --working-directory doesn't work
gnome-terminal option --working-directory doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-10-22 16:34 EDT by matteo porta
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 00:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My patch to fix this. Put as patch 6 in the RH 8.0 gnome-terminal src.rpm (1011 bytes, patch)
2002-11-12 19:34 EST, Jonathan Briggs
no flags Details | Diff

  None (edit)
Description matteo porta 2002-10-22 16:34:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
in the gnome-terminal program the --working-directory doesn't work at all! (i
need it to add a nautilus script to open the terminal in the dir currently
showed in nautilus).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run gnome-terminal --working-directory=<somedir>
2. it open in the user's home.
3.
	

Additional info:
Comment 1 Jonathan Briggs 2002-11-12 19:34:05 EST
Created attachment 84744 [details]
My patch to fix this.  Put as patch 6 in the RH 8.0 gnome-terminal src.rpm
Comment 2 Havoc Pennington 2003-01-08 00:59:02 EST
Can you explain the patch and why it's required? Looks like a workaround 
for a vte bug.

It does seem to work fine in latest rawhide though, so perhaps it was fixed.

Note You need to log in before you can comment on or make changes to this bug.