This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 765300 - (GLUSTER-3568) rebalance operation failed where as glusterd log shows succeeded and core dumped
rebalance operation failed where as glusterd log shows succeeded and core dumped
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-release
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 03:02 EDT by shylesh
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mount log (4.73 KB, text/x-log)
2011-09-16 00:02 EDT, shylesh
no flags Details
glusterd (2.47 KB, text/x-log)
2011-09-16 00:03 EDT, shylesh
no flags Details

  None (edit)
Description shylesh 2011-09-16 00:03:01 EDT
Created attachment 662
Comment 1 shylesh 2011-09-16 01:45:41 EDT
This scenario also happens on distribute setup.
Comment 2 shylesh 2011-09-16 03:02:11 EDT
1. Create a stripe volume with count 2 
2. fill up the volume with few files
3. add 2 more bricks and initiate rebalance

Bug
----
status initially shows fix-layout progress and migration. After sometime status says rebalance failed.

(attached the logs)
Comment 3 shylesh 2011-09-27 06:28:31 EDT
warning from valgrind logs

Thread 1:
==2375== Syscall param writev(vector[...]) points to uninitialised byte(s)
==2375==    at 0x3AA38CD293: writev (in /lib64/libc-2.5.so)
==2375==    by 0x62E457E: send_fuse_iov (fuse-bridge.c:59)
==2375==    by 0x62E46EC: send_fuse_data (fuse-bridge.c:95)
==2375==    by 0x62E5E6C: fuse_attr_cbk (fuse-bridge.c:402)
==2375==    by 0x62E603D: fuse_root_lookup_cbk (fuse-bridge.c:434)
==2375==    by 0xC0AC0EA: io_stats_lookup_cbk (io-stats.c:1415)
==2375==    by 0xBE843F9: sp_lookup_cbk (stat-prefetch.c:919)
==2375==    by 0xBC68548: qr_lookup_cbk (quick-read.c:440)
==2375==    by 0xBA54DF6: ioc_lookup_cbk (io-cache.c:266)
==2375==    by 0x4C29A75: default_lookup_cbk (defaults.c:46)
==2375==    by 0x4C29A75: default_lookup_cbk (defaults.c:46)
==2375==    by 0xB3FC655: dht_revalidate_cbk (dht-common.c:420)
==2375==  Address 0x7fefffa6c is on thread 1's stack
==2375==
==2375== Warning: client switching stacks?  SP change: 0xccbb0d8 --> 0x17841028
==2375==          to suppress, use: --max-stackframe=179855184 or greater
==2375== Warning: client switching stacks?  SP change: 0xccbb0d8 --> 0x17840aa0
==2375==          to suppress, use: --max-stackframe=179853768 or greater
==2375== Warning: client switching stacks?  SP change: 0x178409b8 --> 0xccbb0e0
==2375==          to suppress, use: --max-stackframe=179853528 or greater
==2375==          further instances of this message will not be shown.
==2375==
Comment 4 Amar Tumballi 2011-10-02 18:56:54 EDT
With bug 765368 getting fixed, the coredump issue seems to be fixed. Please reopen if seen again.

Note You need to log in before you can comment on or make changes to this bug.