Bug 76532 - Right clicking in nedit causes the monitor to flicker and a resolution "reset"
Right clicking in nedit causes the monitor to flicker and a resolution "reset"
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
athlon Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 82784
  Show dependency treegraph
Reported: 2002-10-22 17:39 EDT by Shawn Walker
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-04-02 21:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Shawn Walker 2002-10-22 17:39:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Right clicking in nedit causes the monitor to flicker and a resolution "reset".
2 seperate machines both do this consistently. Start X, open nedit, right click
in the editing area, the whole screen will flicker and the monitor will blank
out as if it's changing resolutions.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start X
2. Open nedit
3. right click in editing area

Actual Results:  The screen will flicker the first time you right click, and
subsequent times the monitor will black out as if it's changing resolution and
the image will then come back.

Expected Results:  This should not happen.

Additional info:

2 seperate machines do this. This is using the standard "nv" driver that comes
with RedHat 8.0, NOT the "nvidia" one. Although it does it with their driver too.
Comment 1 Shawn Walker 2002-10-22 17:40:06 EDT
BTW, I did try lots of other applications, no other ones do it. Just nedit as
far as I can tell. It may have something to do with the fact that it's an motif
based application and uses openmotif under RedHat, other than that I have no idea.
Comment 2 Shawn Walker 2002-10-25 16:50:07 EDT
I tried the current CVS version of NEdit, it does this as well. This leads me to
believe it's something in the RedHat build of OpenMotif. I'll do some more
Comment 3 Shawn Walker 2002-10-31 11:58:28 EST
Even using the precompiled version of NEdit from http://www.nedit.org/ which has
OpenMotif 2.1 statically linked against it does not resolve this issue. If I
hold down the right mouse button X will drop video signal and the monitor will
turn off, the instant I let go of the right mouse button and move the mouse
again, suddenly I have a video signal again. This only seems to affect Motif
applications, and the only thing I can guess so far is it has to do something
with libxm or libxmu in RedHat. Debian doesn't do this, and Gentoo doesn't do
this. This is incredibly disturbing.
Comment 4 Tim Waugh 2002-12-23 06:53:56 EST
I guess it must be an X problem, although I can no longer reproduce the problem.
 Do you still see this problem with the current rawhide packages?
Comment 5 Shawn Walker 2002-12-23 10:57:16 EST
Which current Rawhide packages would I need to install?
Comment 6 Tim Waugh 2002-12-23 11:52:50 EST
nedit, XFree86 etc, openmotif.
Comment 7 Shawn Walker 2002-12-23 13:49:52 EST
I'll try just the new nedit RPM you have out for a while and see if I can
reproduce it still. If that doesn't work, I'll additionally upgrade XFree86,
etc. Thanks.
Comment 8 Shawn Walker 2002-12-25 19:33:45 EST
Well, since using the new NEdit binary from Rawhide the problem seems to have
gone away. I'm not sure why. But it seems to be solved. You can go ahead and
close this bug, and if I see the issue again later I'll re-open it. Thanks.
Comment 9 Shawn Walker 2002-12-26 15:37:44 EST
It's back. It seems like this only happens on a fresh boot, after a while of
running the system for a day or so it goes away apparently. I'm going to try the
new rawhide XFree86 and OpenMotif packages.
Comment 10 Shawn Walker 2003-01-20 13:53:39 EST
Finally, after installing the phoebe beta in hopes this would go away and
finding that it did not, I have found 100% reproduceable steps for this to happen.

I get flicker if I right click in the editor following these steps:
1) Do a fresh login
2) Start XMMS, play ogg file
3) Start nedit, right click in editor

And if after the above, I close XMMS, and then go back to nedit, it will only
flicker once more if I right-click multiple times, and if I start XMMS back up
and play a file, nedit will still not flicker from there on out during that
login session. I'm using the OSS driver for sound output in XMMS.

However, if I do the following I get no annoying flicker at all:
1) Do a fresh login
2) Start Nedit, right click
3) Start XMMS, play ogg file
4) Right click in nedit

I hope this helps.
Comment 11 Tim Waugh 2003-01-21 12:46:53 EST
Openmotif problem?
Comment 12 Tim Waugh 2003-01-21 12:47:23 EST
XFree86 problem?

I just don't know.
Comment 13 Shawn Walker 2003-01-21 12:54:53 EST
Well, tell me how I can debug this please. All I know is that there is some sort
of interaction on RedHat systems that causes this. I never saw this in Gentoo or

I'm a programmer by trade, so I'm willing to rip the guts of a few things open
if necessary.
Comment 14 Mike A. Harris 2003-01-22 11:47:00 EST
Definitely an XFree86 server bug of some kind.  Might or might not be
video driver specific.  Unknown.

There are now 3 bugs in bugzilla of similar behaviour like this.  The
things in common to all of them is:

1) Only occurs with Motif applications
2) Only occurs when right clicking in a motif app, and popping up a
   pulldown menu

Most likely it would require debugging the X server and possibly the
video driver, although I heavily suspect it is the X server itself.

It is _definitely_ not an nedit or Motif bug though.
Comment 15 Shawn Walker 2003-01-22 11:51:16 EST
What's odd to me is the fact that XMMS specifically seems cause the problem to
reproduce itself consistently on my system.

Your thoughts on this seem to concur with my findings so far. To see if it's
specifically the "nv" driver, I will try the vesa driver later today and report
back the results. If it doesn't happen with the vesa driver then that should
help narrow things quite a bit.
Comment 16 Tim Waugh 2003-01-22 11:54:08 EST
I've seen this myself with a driver we actually ship.
Comment 17 Shawn Walker 2003-01-22 11:57:49 EST
Just so it's explicitly clear, i'm using the *standard* "nv" driver that comes
with RedHat, I have not ever installed the official NVidia drivers for this
installation of RedHat.
Comment 18 Mike A. Harris 2003-01-22 14:40:07 EST
It is almost certainly a 2D acceleration related bug.  My best guess is
that it is something buried inside the XAA code common to all drivers.

It is probably not too difficult to debug once reproduced locally here.
It's more of a matter now of prioritization and alloting the time to
debug it.

I'll update the report when it's on my priority todo list.

Thanks for all the above info BTW
Comment 19 Shawn Walker 2003-02-06 12:15:04 EST
As a side note, this doesn't appear to occur ever when using KDE as my desktop
instead of gnome with RH8. metacity issue perhaps?
Comment 20 Shawn Walker 2003-04-02 18:32:03 EST
This appears to be gone in RedHat 9 so far.
Comment 21 Mike A. Harris 2003-04-02 21:07:49 EST
Closing as CURRENTRELEASE (Red Hat Linux 9)

Note You need to log in before you can comment on or make changes to this bug.