Bug 765339 - (GLUSTER-3607) nfs: crash happening while mounting the volume
nfs: crash happening while mounting the volume
Status: CLOSED DUPLICATE of bug 765279
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Krishna Srinivas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-22 02:17 EDT by Saurabh
Modified: 2011-09-22 04:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-09-21 23:48:37 EDT
As per the trace, replicate is the last component where crash happened. Assigning it to Pranith.
Comment 1 Saurabh 2011-09-22 01:23:49 EDT
some information about this bug, as I tried again and the mount worked properly,


[root@Centos1 ~]# mount -t nfs -o vers=3,nolock 10.1.12.134:/dist-rep/d1 /mnt/nfs-test
[root@Centos1 ~]# cd /mnt/nfs-test
[root@Centos1 nfs-test]# ls
[root@Centos1 nfs-test]# touch a
[root@Centos1 nfs-test]# mkdir dir
[root@Centos1 nfs-test]# ls -l
total 20
-rw-r--r-- 1 root root    0 Sep 22 04:07 a
drwxr-xr-x 2 root root 8192 Sep 22 04:07 dir
[root@Centos1 nfs-test]# 
[root@Centos1 nfs-test]# 
[root@Centos1 nfs-test]# mkdir a
mkdir: cannot create directory `a': File exists
[root@Centos1 nfs-test]# ls
a  dir
[root@Centos1 nfs-test]# 


for the crash mentioned in the earlier post, here is the backtrace,

(gdb) bt
#0  afr_unlock_inodelk_cbk (frame=0x2b1ce096b0ac, cookie=0x0, this=0x10b28e50, op_ret=0, op_errno=0) at afr-lk-common.c:572
#1  0x00002aaaaaac6854 in client3_1_inodelk_cbk (req=<value optimized out>, iov=<value optimized out>, count=<value optimized out>, 
    myframe=0x2b1ce06daf84) at client3_1-fops.c:1228
#2  0x00002b1cdfa4e3f2 in rpc_clnt_handle_reply (clnt=0x10b6fe30, pollin=<value optimized out>) at rpc-clnt.c:736
#3  0x00002b1cdfa4e5ed in rpc_clnt_notify (trans=<value optimized out>, mydata=0x10b6fe60, event=<value optimized out>, data=0x0)
    at rpc-clnt.c:849
#4  0x00002b1cdfa49287 in rpc_transport_notify (this=0x2b1ce096b0ac, event=RPC_TRANSPORT_ACCEPT, data=0x0) at rpc-transport.c:919
#5  0x00002aaaad99feef in socket_event_poll_in (this=0x10b6ffa0) at socket.c:1647
#6  0x00002aaaad9a0098 in socket_event_handler (fd=<value optimized out>, idx=0, data=0x10b6ffa0, poll_in=1, poll_out=0, poll_err=0)
    at socket.c:1762
#7  0x00002b1cdf80d771 in event_dispatch_epoll_handler (event_pool=0x10b1e360) at event.c:794
#8  event_dispatch_epoll (event_pool=0x10b1e360) at event.c:856
#9  0x000000000040534f in main (argc=7, argv=0x7fff6ce4eb18) at glusterfsd.c:1509
(gdb)
Comment 2 Pranith Kumar K 2011-09-22 01:32:22 EDT

*** This bug has been marked as a duplicate of bug 3547 ***
Comment 3 Saurabh 2011-09-22 02:17:09 EDT
patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2011-09-22 02:02:46
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.2.4qa2
/lib64/libc.so.6[0x3b854302d0]
/opt/glusterfs/3.2.4qa2//lib/glusterfs/3.2.4qa2/xlator/cluster/replicate.so[0x2aaaaad1c2e9]
/opt/glusterfs/3.2.4qa2//lib/glusterfs/3.2.4qa2/xlator/protocol/client.so(client3_1_inodelk_cbk+0xc4)[0x2aaaaaac6854]
/opt/glusterfs/3.2.4qa2//lib/libgfrpc.so.0(rpc_clnt_handle_reply+0xa2)[0x2b1cdfa4e3f2]
/opt/glusterfs/3.2.4qa2//lib/libgfrpc.so.0(rpc_clnt_notify+0x8d)[0x2b1cdfa4e5ed]
/opt/glusterfs/3.2.4qa2//lib/libgfrpc.so.0(rpc_transport_notify+0x27)[0x2b1cdfa49287]
/opt/glusterfs/3.2.4qa2//lib/glusterfs/3.2.4qa2/rpc-transport/socket.so(socket_event_poll_in+0x3f)[0x2aaaad99feef]
/opt/glusterfs/3.2.4qa2//lib/glusterfs/3.2.4qa2/rpc-transport/socket.so(socket_event_handler+0x188)[0x2aaaad9a0098]
/opt/glusterfs/3.2.4qa2//lib/libglusterfs.so.0[0x2b1cdf80d771]
/opt/glusterfs/3.2.4qa2//sbin/glusterfs(main+0x42f)[0x40534f]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x3b8541d994]
/opt/glusterfs/3.2.4qa2//sbin/glusterfs[0x403669]

Note You need to log in before you can comment on or make changes to this bug.