Bug 765363 - (GLUSTER-3631) zero byte files when perl search and replace script
zero byte files when perl search and replace script
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quick-read (Show other bugs)
3.2.3
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Raghavendra G
:
: 800381 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-09-26 03:21 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:03:55 EDT
Type: ---
Regression: RTA
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2011-09-26 03:21:58 EDT
Reported on a user mailing list. When perl search and replace string command is used, it created zero byte files. Happens only when executed manually but works fine when executed within a script.

This issue is not seen with quick-read disabled.



echo 'test' > dot

perl -i -pe 's/test/somethingelse/' dot

ls -lh dot
-rw-r--r-- 1 root root 0 2011-09-26 11:43 dot
Comment 1 Raghavendra G 2011-11-10 20:30:07 EST
Patch sent, waiting for it to be pulled in.
Comment 2 Amar Tumballi 2011-12-08 02:39:47 EST
please work on review comments and resubmit.
Comment 3 Anand Avati 2012-03-28 13:40:48 EDT
CHANGE: http://review.gluster.com/506 (performance/quick-read: make unlink aware of open-behind behaviour of quick-read.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 4 Anand Avati 2012-03-29 02:02:58 EDT
CHANGE: http://review.gluster.com/3028 (performance/quick-read: fix build errors.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 5 shishir gowda 2012-03-29 03:21:41 EDT
*** Bug 800381 has been marked as a duplicate of this bug. ***
Comment 6 Anush Shetty 2012-03-29 08:27:11 EDT
Verified in the mainline [fbfb4d48491b160436e6ac986057a8fe5e320502]

Note You need to log in before you can comment on or make changes to this bug.