Bug 765399 - (GLUSTER-3667) 1 gluster box locks up the filesystem due to a kernel errors
1 gluster box locks up the filesystem due to a kernel errors
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.2.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 07:39 EDT by Ben Copeland
Modified: 2015-05-26 08:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 07:09:28 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vbellur: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Ben Copeland 2011-09-29 07:39:13 EDT
Hi all,

I have 4 identical servers. Running debian squeeze. 1 server runs ucarp and samba. The others just run gluster. However one of the gluster boxes gets stuck in some sort kernel gluster loop which causes glusterfs to completely lock up.

A small paste of the log is here:

http://pastie.org/private/sqj30jpvoxsttfik4gpew

A full paste of the log can be found here:


I have glusterfs mounted on each box. This mounted so samba can access the files.

in fstab:

bfs3:/data-volume       /san/gluster/data-volume        glusterfs defaults,_netdev,noatime  0 0

Why does it do this? And only on 1 server. The other 3 are fine. Its a pretty bad problem since it locks up the mount point...
Comment 1 Rajesh 2011-10-10 03:40:16 EDT
Hi Ben,on what set-up is this happening? Can you please provide the gluster logs,especially the brick/server(glusterfsd) logs, it will help in identifying why this happens. Also, please specify the backend filesystem(s) in use.
Comment 2 Amar Tumballi 2012-02-28 03:32:54 EST
Ben, We are coming out with 3.3.0alpha release soon. Please feel free to try it and let us know the behavior.
Comment 3 Niels de Vos 2015-05-26 08:33:43 EDT
This bug has been CLOSED, and there has not been a response to the requested NEEDINFO in more than 4 weeks. The NEEDINFO flag is now getting cleared so that our Bugzilla household is getting more in order.

Note You need to log in before you can comment on or make changes to this bug.