Bug 7654 - rpm can't install directories read-only
rpm can't install directories read-only
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-07 12:30 EST by mp
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-08 07:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mp 1999-12-07 12:30:21 EST
Making any directories to be installed read-only, results in cpio
/*So this may be indeed a cpio bug.*/ complaining about not being able to
write into these directories [at ``rpm -U''-time].

Separating the act of writing files and the act of adjusting permissions
[doing the latter bottom up, like GNU-``chmod -R'' does] would eliminate
the problem.

This feature is especially important, since in a non-root environment,
the only means to protect your rpm installation from your own faults is
file permissions.
Comment 1 Jeff Johnson 1999-12-08 07:52:59 EST
This is mainly a packaging rather than an rpm issue. Most packages have
directories that are "read-only" for (at least) others, and rpm installs
those directories, and files therein, quite well. Rpm packages also include
owners, groups and modes that can be different than those inside the gzipped
cpio payload, so conforming to the tyranny of /bin/cpio (which rpm does not
use to install packages) requirements is not an issue.

Is the issue that you wish to package 0555 directories? If so, you should
be able to install your package as root (the id that always has write
permission) and package with non-root owner/mode for directories. If that
is not the case, please reopen this bug with an example specfile that
cannot install 0555 directories as root.

Note You need to log in before you can comment on or make changes to this bug.