Bug 76546 - kernel-2.4.18-17.7.x won't power off
kernel-2.4.18-17.7.x won't power off
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 00:52 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version: 2.4.20-13.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-17 00:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-23 00:52:39 EDT
After updating my 7.3 athlon system to this kernel, it will no longer power off
on shutdown.

It looks like apm is being disabled and it wasn't in the previous errata kernel.

This (from /var/log/dmesg) wasn't in the previous kernel..
"Jabil AMD machine detected. Disabling APM idle."

and then further down I see...
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
apm: disabled on user request.

Also, not disabled in previous kernel.

I tried adding "apm=on" to kernel boot, but the system hung while/or just after
initializing my scsi card. Adaptec 290x. Again, this wasn't a problem in the
previous errata kernel which had apm enabled.

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8
        <Adaptec 2902/04/10/15/20/30C SCSI adapter>
        aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs

blk: queue c1a7e618, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: ARCHIVE   Model: VIPER 150  21247  Rev: -011
  Type:   Sequential-Access                  ANSI SCSI revision: 01
blk: queue c1814218, I/O limit 4095Mb (mask 0xffffffff)


I also don't see APIC being initialized, which was in the previous kernel. (And
didn't cause any problems on my system).

/proc/cpuinfo:

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 2
model name	: AMD Athlon(tm) Processor
stepping	: 1
cpu MHz		: 798.450
cache size	: 512 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx
fxsr syscall mmxext 3dnowext 3dnow
bogomips	: 1586.32
Comment 1 Need Real Name 2003-05-17 00:42:38 EDT
This bug is now fixed with errata kernel-2.4.20-13.7

Note You need to log in before you can comment on or make changes to this bug.