Bug 76555 - problems with kernel-2.4.18-17.8.0 on Dell Latitude CPx
problems with kernel-2.4.18-17.8.0 on Dell Latitude CPx
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-23 08:01 EDT by Chris Runge
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-16 06:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2002-10-23 08:01:05 EDT
Description of Problem:

I have found at least two problems with the errata kernel-2.4.18-17.8.0 on 8.0
(these apply to the version compiled for 7.2 as well when run on a 7.2 system):

(1) The system hangs when starting up or shutting down. I unfortunately cannot
reproduce the hang when it starts up any longer, but seemed to occur towards the
end of the initscripts for runlevel 3. The hang during the shutdown is
reproduceable everytime and occurs right at the end of the shutdown sequence
(when pcmcia services are brought down, but before all processes are killed).
Rebooting with the original kernel solved the problem in both cases.

(2) Odd sounds coming from the system. I know this seems a little odd, but there
were be audible squeaks and squeals that seem to come from the system's
speakers. Again, older kernels did not have this problem.

Both problems occur on a Dell Latitude CPx laptop (P3 650, 192 MB of RAM, Xircom
Realport PCMCIA card with 10/100+modem, 8 MB Rage Mobility video, Maestro 3
audio). They do not occur on any other system I have tried this kernel on.

Version-Release number of selected component (if applicable):

Comment 1 Chris Runge 2002-11-09 18:33:29 EST
I've tried the same Xircom PCMCIA card on an IBM T30 laptop--I get similar
problems with the latest 8.0 kernel errata. My guess is that the issue is a
kernel-Xircom one rather than having anything to do with the Dell.
Comment 2 Arjan van de Ven 2002-11-10 04:48:58 EST
please try the test kernel at 
as that's supposed to have fixes for both maestro and xircom
Comment 3 Arjan van de Ven 2002-11-16 06:07:03 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.