Bug 76556 - kernel-source: Makefile and version.h disagree on "extra version"
kernel-source: Makefile and version.h disagree on "extra version"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 08:05 EDT by Aleksey Nogin
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 19:39:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-10-23 08:05:30 EDT
In kernel-source-2.4.18-17.8.0 the top-level Makefile specifies
EXTRAVERSION = -17.8.0custom
However include/linux/version.h will define UTS_RELEASE using the normal "stock"
naming scheme (2.4.18-17.8.0smp/2.4.18-17.8.0BOOT/2.4.18-17.8.0bigmem/...). As a
result, the modules (under "make modules_install") will be installed in one
directory, but then looked up in a different one!
IMHO, include/linux/version.h should use the same version Makefile uses.
Comment 1 Arjan van de Ven 2002-10-23 13:45:02 EDT
nope
the version.h is set up so that you can compile external kernel modules against
the kernel-source. Once you start a full compile it will automatically be
overwritten with the EXTRAVERSION from the makefle.
Comment 2 Aleksey Nogin 2002-10-23 17:50:40 EDT
Well, the reason I filed this bug is that I have compiled a custom kernel, and
than had to figure out why it couldn't find any modules...
Comment 3 Arjan van de Ven 2002-10-24 04:19:34 EDT
did you run mrproper?
What steps did you run to compile your custom kernel?
(it might well be that there's a dependency missing somewhere)
Comment 4 Aleksey Nogin 2002-10-24 16:45:51 EDT
> did you run mrproper?

No

> What steps did you run to compile your custom kernel?

If I am not mistaken, I edited .config (base on RedHat's one), then make
oldconfig, make dep, make bzImage, make modules, make modules_install, make install.
Comment 5 Dave Jones 2003-12-16 19:39:15 EST
You need to run mrproper first.

Note You need to log in before you can comment on or make changes to this bug.