Bug 765622 - [abrt] telepathy-butterfly-0.5.15-3.fc16: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/_3123a5899_40sina_2ecom at 0x19cb490>
[abrt] telepathy-butterfly-0.5.15-3.fc16: connmgr.py:65:disconnected:KeyError...
Status: CLOSED DUPLICATE of bug 691209
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
abrt_hash:01f6bb270a24cfdd133aabcbd8f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 18:15 EST by yangqi89
Modified: 2011-12-08 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-08 20:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (3.07 KB, text/plain)
2011-12-08 18:15 EST, yangqi89
no flags Details

  None (edit)
Description yangqi89 2011-12-08 18:15:46 EST
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         3.1.2-1.fc16.x86_64
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/_3123a5899_40sina_2ecom at 0x19cb490>
time:           Thu 08 Dec 2011 10:28:47 PM CST
uid:            500
username:       yq

smolt_data:     Text file, 3142 bytes

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/_3123a5899_40sina_2ecom at 0x19cb490>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/_3123a5899_40sina_2ecom at 0x19cb490>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x19bf950>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/_3123a5899_40sina_2ecom at 0x19cb490>
Comment 1 yangqi89 2011-12-08 18:15:48 EST
Created attachment 544244 [details]
File: smolt_data
Comment 2 Brian Pepple 2011-12-08 20:19:59 EST

*** This bug has been marked as a duplicate of bug 691209 ***

Note You need to log in before you can comment on or make changes to this bug.