Bug 76565 - RedHat 7.3 errata breaks netscape plugins
RedHat 7.3 errata breaks netscape plugins
Status: CLOSED DUPLICATE of bug 75128
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 10:39 EDT by Jeremy Sanders
Modified: 2016-11-24 09:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-23 10:40:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Sanders 2002-10-23 10:39:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
The RedHat 7.3 errata for glibc, glibc-2.2.5-40, breaks plugins for Netscape
4.x. If a page with a plugin is encountered (e.g. java, realplayer), then
netscape core dumps.

Both downloaded (from netscape) and RedHat provided Netscapes crash. Using glibc
2.2.5-39 works fine.

 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade glibc to 2.2.5-40
2. Run netscape
3. Go to http://sunsite.org.uk/
	

Actual Results:  Netscape core dumps

Expected Results:  Netscape starts plugin

Additional info:

A backtrace on the core file shows:
#0  0x40244f10 in _nss_dns_gethostbyname2_r () from /lib/libnss_dns.so.2
#1  0x40246315 in _nss_dns_gethostbyname_r () from /lib/libnss_dns.so.2
#2  0x420f8551 in gethostbyname_r@@GLIBC_2.1.2 () from /lib/i686/libc.so.6
#3  0x420f7f1d in gethostbyname () from /lib/i686/libc.so.6
#4  0x089361d7 in PR_gethostbyname ()
#5  0x08740b38 in java_net_InetAddressImpl_lookupAllHostAddr ()
#6  0x0871932d in Java_java_net_InetAddressImpl_lookupAllHostAddr_stub ()
#7  0x0870573a in invokeNativeMethod ()
#8  0x08705cdd in invokeLazyNativeMethod ()
#9  0x08708d70 in ExecuteJava ()
#10 0x0870a907 in do_execute_java_method_vararg ()
#11 0x0870a318 in execute_java_dynamic_method ()
#12 0x08719adf in java_lang_System_setSystemIO ()
#13 0x08742788 in start_thread ()
#14 0x0893f98c in HopToad ()
#15 0x0893f9cb in HopToadNoArgs ()
#16 0x0893fa34 in PR_Start ()
Comment 1 Jakub Jelinek 2002-10-23 10:42:55 EDT

*** This bug has been marked as a duplicate of 75128 ***

Note You need to log in before you can comment on or make changes to this bug.