This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 765675 - The printout font shades problem
The printout font shades problem
Status: CLOSED DUPLICATE of bug 485566
Product: Fedora
Classification: Fedora
Component: paps (Show other bugs)
15
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 23:40 EST by mwu
Modified: 2011-12-09 00:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-09 00:44:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The paps output without font setting (23.86 KB, application/postscript)
2011-12-08 23:40 EST, mwu
no flags Details
The paps output with font setting (23.60 KB, application/postscript)
2011-12-08 23:42 EST, mwu
no flags Details

  None (edit)
Description mwu 2011-12-08 23:40:25 EST
Created attachment 544347 [details]
The paps output without font setting

Description of problem:
    When we use "paps" to convert a text file with Traditional Chinese and English fonts, the Traditional Chinese printout fonts will be lighter than the English fonts. If we specify the font in the command, e.g. " paps --font='DejaVu Sans Mono' test.txt > test.ps ", then the printout font shades will look like the same for both the Traditional Chinese and the English fonts. Because we don't see the problem in Fedora Core 6, please check to see if we can use "paps" to convert the text directly without specifying the fonts extraly. Thank you for your assistance.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. excute the command " paps test.txt > test.ps "
2.
3.
  
Actual results:
The Traditional Chinese printout font is lighter than the English printout font.

Expected results:
The printout font shades is the same for both the Traditional Chinese font and the English font.

Additional info:
Comment 1 mwu 2011-12-08 23:42:00 EST
Created attachment 544348 [details]
The paps output with font setting
Comment 2 Akira TAGOH 2011-12-09 00:44:04 EST
This isn't a paps issue but pango, because it depends on how pango splits the cluster. you can see same behavior on gedit say. though it could be improved with the fontconfig configuration as you pointed out it looks no problem with specifying the font name. anyway, we have similar bug on bugzilla. I'll close this as dup of it so far.

*** This bug has been marked as a duplicate of bug 485566 ***

Note You need to log in before you can comment on or make changes to this bug.