Bug 765728 - Need to export all virt-who env variables in virt-who-initscript
Need to export all virt-who env variables in virt-who-initscript
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: TestBlocker
Depends On:
Blocks: 715031 754330 759462 769266
  Show dependency treegraph
 
Reported: 2011-12-09 04:06 EST by Keqin Hong
Modified: 2012-02-21 01:07 EST (History)
6 users (show)

See Also:
Fixed In Version: virt-who-0.5-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keqin Hong 2011-12-09 04:06:52 EST
Description of problem:
Current virt-who-initscript (install virt-who-initscript $(DESTDIR)/etc/rc.d/init.d/virt-who
)  exported only two env vars: 
"
export VIRTWHO_BACKGROUND
export VIRTWHO_DEBUG
"

As a result, virt-who on rhev-h is not to able to work properly since VIRTWHO_VDSM env var is not exported.

Version-Release number of selected component (if applicable):
virt-who-0.4

How reproducible:
100%

Steps to Reproduce:
1. # grep export virt-who-initscript 
export VIRTWHO_BACKGROUND
export VIRTWHO_DEBUG

2.
3.
  
Actual results:
exported only two env vars: VIRTWHO_BACKGROUND and VIRTWHO_DEBUG

Expected results:
export all env of /etc/sysconfig/virt-who

Remove hardcoded exports. program to export all items in /etc/sysconfig/virt-who

Additional info:
Comment 2 Radek Novacek 2011-12-13 09:34:26 EST
This bug should be fixed in virt-who-0.5-1.el5

https://brewweb.devel.redhat.com/taskinfo?taskID=3889752
Comment 5 errata-xmlrpc 2012-02-21 01:07:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0225.html

Note You need to log in before you can comment on or make changes to this bug.