Bug 76574 - Javascript hangs browser
Javascript hangs browser
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 12:12 EDT by Derek Atkins
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-23 12:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2002-10-23 12:12:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I was browsing at ebs.adp.com, clicked a (javascript) link, and the browser
hangs.  This is 100% reproducible using the RH7.3 mozilla RPM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start mozilla
2.go to ebs.adp.com
3.in the form on the left, put in some values (it doesn't appear to matter, but
I put in 1, monthly, 02144, postmaster@adp.com), then submit the form.
4.click the "start over" link and watch your browser hang.
	

Actual Results:  After performing the above steps, by browser hangs
indefinitely.  I have to kill the window, and then manually kill the leftover
mozilla processes in order to restart.

You lose any data you were working on, or any state in open mozilla windows.

Expected Results:  Mozilla should either report an error in the javascript or
work.  It should not hang.

Additional info:

mozilla-dom-inspector-1.0.1-2.7.3
mozilla-1.0.1-2.7.3
mozilla-js-debugger-1.0.1-2.7.3
mozilla-psm-1.0.1-2.7.3
mozilla-nspr-1.0.1-2.7.3
mozilla-nss-1.0.1-2.7.3
Comment 1 Derek Atkins 2002-10-25 18:52:26 EDT
This turns out to have been a Java, not Javascript, problem.  I upgraded my java
plugin to the j2-1.4.1 plugin and this problem went away.  Therefore I am
closing this bug for you.  Have a nice day :)

Note You need to log in before you can comment on or make changes to this bug.