Bug 76577 - terminal messing up with SSH & screen
terminal messing up with SSH & screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 12:32 EDT by Emmanuel Galanos
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-22 10:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2002-10-23 12:32:04 EDT
Description of Problem:
I am SSHing into a 7.0 box upon which I run screen and read my
email using mutt. My desktop is running 8.0. Screen redraws are
getting messed up in mutt (example status line can appear in middle
of screen). Switching to another screen and back again redraws screen
properly. Using a 7.3 machine & gnome-terminal does not show this
problem. Xterm on 8.0 works correctly also. Mutt run directly not
through screen also works.

Version-Release number of selected component (if applicable):
8.0 with all updates + Jakub's 2.3.1 glibc test RPM's on desktop.
7.0 server.

How Reproducible:
100 %

Steps to Reproduce:
1. On a 7.0 box run screen, and mutt from inside it.
2. on 8.0 box with default gnome-terminal settings and en_AU locale
   SSH in 7.0 box and attach to session.
3. Read email and pull out hair as screen gets messed up.

Actual Results:
Text not being displayed. Characters being displayed in middle of screen.

Expected Results:
Screen redraws to work like in 7.3.
Comment 1 John Verel 2003-01-07 21:20:07 EST
Precisely the same results as above, same conditions, only ssh-ing int a
Mandrake Linux 8.2 box.
Comment 2 Emmanuel Galanos 2003-02-25 00:14:02 EST
This is still broken in the latest RH beta. Currently using vte 0.10.20-1.
This is a really bad regression from RH 7.3.
Comment 3 Ray Strode [halfline] 2004-06-15 14:22:21 EDT
Are you still having this problem with fc2?
Comment 4 Ray Strode [halfline] 2004-06-22 10:45:36 EDT
I'm going to close the bug because a lot of code has changed since it
was reported.  If you still have problems please reopen it.

Note You need to log in before you can comment on or make changes to this bug.