Bug 765807 - Messages to moderated queues are put in shunt box
Summary: Messages to moderated queues are put in shunt box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman
Version: 6.2
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks: 836169 947775 1070830 1159820 1232795
TreeView+ depends on / blocked
 
Reported: 2011-12-09 13:59 UTC by Peter Reuterås
Modified: 2018-12-06 14:42 UTC (History)
4 users (show)

Fixed In Version: mailman-2.1.12-19.el6
Doc Type: Bug Fix
Doc Text:
Previously, an incompatibility between Python in Red Hat Enterprise Linux 6 and the Mailman project occurred. Consequently, when moderators were approving a moderated message to a mailing list and checked the "Preserve messages for the site administrator" checkbox, Mailman failed to approve the message and returned an error. This incompatibility has been fixed, and Mailman now approves messages as expected in this scenario.
Clone Of:
: 1232795 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:41:42 UTC


Attachments (Terms of Use)
proposed patch (739 bytes, patch)
2011-12-12 09:59 UTC, Jan Kaluža
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1417 normal SHIPPED_LIVE Moderate: mailman security and bug fix update 2015-07-20 18:06:40 UTC

Description Peter Reuterås 2011-12-09 13:59:51 UTC
Description of problem:

After the latest update to mailman queues that are moderated get their messages delivered to the shunt folder.

Version-Release number of selected component (if applicable):

mailman-2.1.12-17.el6

How reproducible:

Every message sent to moderated list is put in the shunt folder.

Steps to Reproduce:
1. Send message to a moderated queue
2. Message is delivered to shunt folder 

  
Actual results:

The following is logged in /var/log/mailman/error:

Dec 09 13:52:56 2011 (2376) Uncaught runner exception: Generator instance has no __call__ method
Dec 09 13:52:56 2011 (2376) Traceback (most recent call last):
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 120, in _oneloop
    self._onefile(msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 191, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/IncomingRunner.py", line 130, in _dispose
    more = self._dopipeline(mlist, msg, msgdata, pipeline)
  File "/usr/lib/mailman/Mailman/Queue/IncomingRunner.py", line 153, in _dopipeline
    sys.modules[modname].process(mlist, msg, msgdata)
  File "/usr/lib/mailman/Mailman/Handlers/Moderate.py", line 112, in process
    Hold.hold_for_approval(mlist, msg, msgdata, Hold.NonMemberPost)
  File "/usr/lib/mailman/Mailman/Handlers/Hold.py", line 224, in hold_for_approval
    id = mlist.HoldMessage(msg, reason, msgdata)
  File "/usr/lib/mailman/Mailman/ListAdmin.py", line 205, in HoldMessage
    g(msg, 1)
AttributeError: Generator instance has no __call__ method

Dec 09 13:52:56 2011 (2376) SHUNTING: 1323435176.15872+ca501897059584152642147e3e8c4c191036330e



Expected results:

Message should be delivered to hold queue and moderator notified.


Additional info:

Applied the patch from this conversation from 2009 that solved the problem for now. 

http://www.archivum.info/mailman-users@python.org/2009-09/00133/Re-%28Mailman-Users%29-Error-when-list-Moderator-deals-with-pendingrequests.html

Comment 2 Jan Kaluža 2011-12-12 09:56:34 UTC
This can be fixed by patch mentioned in this mailing thread on mailman-users:

http://osdir.com/ml/mailman-users/2009-09/msg00245.html

Comment 3 Jan Kaluža 2011-12-12 09:59:36 UTC
Created attachment 545648 [details]
proposed patch

Comment 4 Peter Reuterås 2011-12-13 14:25:12 UTC
I've used that patch since the day of the report and it have worked perfectly.

Comment 6 Suzanne Yeghiayan 2012-02-14 23:23:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 21 Alois Mahdal 2015-06-06 17:32:56 UTC
Verified on all architectures.

Comment 23 errata-xmlrpc 2015-07-22 07:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2015-1417.html


Note You need to log in before you can comment on or make changes to this bug.