Bug 76595 - gnome-volume-control doesn't change recording device
Summary: gnome-volume-control doesn't change recording device
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: MoveUpstream, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-23 21:45 UTC by Kirk Morrow
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 02:55:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kirk Morrow 2002-10-23 21:45:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
When selecting a recording device in gnome-volume-control other than the
default, the checkbox is check but the recording device doesn't actually change.
 Exiting g-v-c and restarting will show that the default device (mic on my
system) is still selected.

Version-Release number of selected component (if applicable):
gnome-media-2.0.0-9

How reproducible:
Always

Steps to Reproduce:
1.Open gnome-volume-control
2.Select a recording device other than the one already selected
3.Attempt to record sound using the new input device

Actual Results:  The newly selected device did not record sound.  Also, on
restart on gnome-volume-control, the original device is still shown as the
recording device.

Expected Results:  The newly selected device should have recorded sound.  Also,
on restart on gnome-volume-control, the selected device should be shown as the
recording device.

Additional info:

Athlon 1600+ XP
RedHat 8.0
SB Live!

Problem can be worked around by using aumix to select new recording device.

Comment 1 darkeye 2002-10-29 20:32:51 UTC
I'd just like to second the bug report. I have the same effect on my system.

Comment 2 Havoc Pennington 2002-11-04 21:54:07 UTC
We should report this on bugzilla.gnome.org as well and include a link in each
bug report to the other one.

Comment 3 Havoc Pennington 2003-01-13 02:55:47 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103289


Comment 4 Joachim Haga 2003-05-14 11:41:52 UTC
Actually I think it is
http://bugzilla.gnome.org/show_bug.cgi?id=86783 (which is fixed)

Workaround not complete since aumix doesn't work with f.x. SB extigy (aumix
apparently doesn't honor the "exclusive recording source" flag in OSS.


Note You need to log in before you can comment on or make changes to this bug.