Bug 76601 - network is unreacheble then MAC address of internal nForce Ethernet controller changed
network is unreacheble then MAC address of internal nForce Ethernet controlle...
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 19:43 EDT by Cyril Zlachevsky
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-23 19:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cyril Zlachevsky 2002-10-23 19:43:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.0.1) Gecko/20021003

Description of problem:
If I change default MAC address on onboard Ethernet controller in ifcfg-eth0,
network on this interface not work


Version-Release number of selected component (if applicable):
nForce linux drivers 1.0-0233, 1.0-0236 and 1.0-0241 with kernel 2.4.18-3,
2.4.18-5, 2.4.18-10

How reproducible:
Always

Steps to Reproduce:
STEP 1.
ifcfg-eth script without MAC-address setting look like this:
---[begin /etc/sysconfig/network-scripts/ifcfg-eth0]---
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.1.4
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
# MACADDR=00:10:DC:1D:D1:40
---[end /etc/sysconfig/network-scripts/ifcfg-eth0]---

Network work fine:
---cut---

[root@localhost bug-report]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:DC:1D:D1:4C
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:89 errors:0 dropped:0 overruns:0 frame:0
          TX packets:93 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:7407 (7.2 Kb)  TX bytes:7084 (6.9 Kb)
          Interrupt:11

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
[root@localhost bug-report]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) from 192.168.1.4 : 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.756 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.568 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.379 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.596 ms

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% loss, time 2997ms
rtt min/avg/max/mdev = 0.379/0.574/0.756/0.137 ms

---cut---


STEP 2.
I uncomment MACADDR="00:50:04:71:8D:89" in
/etc/sysconfig/network-scripts/ifcfg-eth0 script:
------[begin /etc/sysconfig/network-scripts/ifcfg-eth0]---
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.1.4
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
MACADDR=00:10:DC:1D:D1:40
---[end /etc/sysconfig/network-scripts/ifcfg-eth0]

STEP 3.
And reboot.
After that network is unreacheble:
---cut---
[root@localhost bug-report]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:DC:1D:D1:40
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:1596 (1.5 Kb)
          Interrupt:11

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2276 (2.2 Kb)  TX bytes:2276 (2.2 Kb)

[root@localhost bug-report]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) from 192.168.1.4 : 56(84) bytes of data.
From 192.168.1.4 icmp_seq=1 Destination Host Unreachable
From 192.168.1.4 icmp_seq=2 Destination Host Unreachable
From 192.168.1.4 icmp_seq=3 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
6 packets transmitted, 0 received, +3 errors, 100% loss, time 5023ms
, pipe 3
---cut---




Additional info:

tested on MSI K7N420 Pro (MS-6373) 
I send to NVidia bug report 10/11/2002 to e-mail linux-nforce-bugs@nvidia.com
but still not have any answear
Comment 1 Arjan van de Ven 2002-10-24 04:23:05 EDT

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.