Bug 766057 - After installing new kernel rpm, grub echos wrong release name
After installing new kernel rpm, grub echos wrong release name
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 17:23 EST by Brad Rubenstein
Modified: 2011-12-11 04:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-11 04:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brad Rubenstein 2011-12-09 17:23:38 EST
I just installed  kernel-PAE-3.1.5-1.fc16.i686
 on a system running kernel-PAE-3.1.4-1.fc16.i686.

When I look at the resulting generated /boot/grub2/grub.cfg, the echo line in the new menu entry shows the wrong release number.

Actual Results:

The generated release menu entry is:

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.5-1.fc16.i686.PAE)' --class fedora --class gnu-linux --class gnu --class os {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='(hd0,msdos2)'
        search --no-floppy --fs-uuid --set=root 91815bb3-ea07-4441-8c14-f915824a9a08
        echo 'Loading Fedora (3.1.4-1.fc16.i686.PAE)'  #### WRONG ####
        linux   /vmlinuz-3.1.5-1.fc16.i686.PAE root=/dev/mapper/vg_br45p2-LogVol00 ro rd.lvm.lv=vg_br45p2/LogVol01 rd.lvm.lv=vg_br45p2/LogVol00 rd.md=0 rd.dm=0  KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks.uuid=luks-e88ca8a1-f9e4-4be4-b21a-4791b35faddb LANG=en_US.UTF-8
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.1.5-1.fc16.i686.PAE.img
}

Expected results:

        echo 'Loading Fedora (3.1.5-1.fc16.i686.PAE)'
Comment 1 Andre Robatino 2011-12-11 04:00:53 EST

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.