Bug 766071 - [abrt] kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-lib.c:1766 iwlagn_set_rxon_chain+0x113/0x233 [iwlagn]()
Summary: [abrt] kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-lib.c:1766 iw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0ddbb1e30599489d84b1b6e59cf...
: 771954 773073 785406 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-09 23:08 UTC by Daniel Mircea
Modified: 2012-02-04 18:42 UTC (History)
9 users (show)

Fixed In Version: kernel-3.2.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-24 07:55:55 UTC
Type: ---


Attachments (Terms of Use)
File: smolt_data (2.51 KB, text/plain)
2011-12-09 23:08 UTC, Daniel Mircea
no flags Details
File: backtrace (2.52 KB, text/plain)
2011-12-09 23:08 UTC, Daniel Mircea
no flags Details

Description Daniel Mircea 2011-12-09 23:08:13 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.4-1.fc16.x86_64 root=UUID=24c17115-49bc-41ad-9e75-46e5b2dd8d08 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.1.4-1.fc16.x86_64
reason:         WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-lib.c:1766 iwlagn_set_rxon_chain+0x113/0x233 [iwlagn]()
time:           Sat 10 Dec 2011 01:06:10 AM EET

backtrace:      Text file, 2579 bytes
smolt_data:     Text file, 2572 bytes

Comment 1 Daniel Mircea 2011-12-09 23:08:17 UTC
Created attachment 544782 [details]
File: smolt_data

Comment 2 Daniel Mircea 2011-12-09 23:08:19 UTC
Created attachment 544783 [details]
File: backtrace

Comment 3 Stanislaw Gruszka 2012-01-21 13:44:26 UTC
This is fixed in upstream 3.3-rc1 by:

commit b2ccccdca46273c7b321ecf5041c362cd950da20
Author: Wey-Yi Guy <wey-yi.w.guy@intel.com>
Date:   Thu Nov 10 06:55:04 2011 -0800

    iwlagn: check for SMPS mode

This commit is not CCed to stable, not sure if it worth to post it there, or maybe just apply it to fedora.

Comment 4 Josh Boyer 2012-01-23 14:34:25 UTC
(In reply to comment #3)
> This is fixed in upstream 3.3-rc1 by:
> 
> commit b2ccccdca46273c7b321ecf5041c362cd950da20
> Author: Wey-Yi Guy <wey-yi.w.guy@intel.com>
> Date:   Thu Nov 10 06:55:04 2011 -0800
> 
>     iwlagn: check for SMPS mode
> 
> This commit is not CCed to stable, not sure if it worth to post it there, or
> maybe just apply it to fedora.

I would suggest having Wey-Yi send it to stable if possible.  I'll backport it to F16 today, but having it in the upstream tree would benefit more than just Fedora.

Comment 5 Josh Boyer 2012-01-23 14:56:15 UTC
Patch applied in Fedora git.  Should be in the next update submitted.

Comment 7 Fedora Update System 2012-01-23 18:31:37 UTC
kernel-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.1-3.fc16

Comment 8 Fedora Update System 2012-01-24 01:44:19 UTC
Package kernel-3.2.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0876/kernel-3.2.1-3.fc16
then log in and leave karma (feedback).

Comment 9 Stanislaw Gruszka 2012-01-24 07:13:44 UTC
*** Bug 771954 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2012-01-24 07:55:55 UTC
kernel-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Josh Boyer 2012-01-30 14:05:23 UTC
*** Bug 785406 has been marked as a duplicate of this bug. ***

Comment 12 Stanislaw Gruszka 2012-02-04 18:42:41 UTC
*** Bug 773073 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.