Bug 766233 - RFE: Support zone transfers in bind-dyndb-ldap
Summary: RFE: Support zone transfers in bind-dyndb-ldap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: beta
: ---
Assignee: Adam Tkac
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On: 804619
Blocks: 701677 767486 827414
TreeView+ depends on / blocked
 
Reported: 2011-12-11 04:09 UTC by Brian J. Atkisson
Modified: 2012-07-16 07:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:51:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0837 normal SHIPPED_LIVE bind-dyndb-ldap bug fix and enhancement update 2012-06-19 20:49:06 UTC
Red Hat Bugzilla 805871 None CLOSED Incorrect SOA serial number set for forward zone during ipa-server installation. 2019-07-24 20:54:59 UTC

Description Brian J. Atkisson 2011-12-11 04:09:25 UTC
Description of problem:
When using the integrated DNS management with IPA, turning on zone transfers in /etc/named.conf does not enable zone transfers.


Version-Release number of selected component (if applicable):
RHEL 6.2
bind-dyndb-ldap-0.2.0-7.el6.x86_64
bind-9.7.3-8.P3.el6.x86_64
ipa-server-2.1.3-9.el6.x86_64


How reproducible: Always


Steps to Reproduce:
1. Add 'allow-transfer { any; };' to the options section of /etc/named.conf
2. restart bind
3. 'dig @ipa-server zone_name AXFR' fails to transfer the zone.

  
Actual results:
dig @ipa-server ZONE AXFR

; <<>> DiG 9.8.1-P1-RedHat-9.8.1-4.P1.fc16 <<>> @192.168.1.2 ZONE AXFR
; (1 server found)
;; global options: +cmd
; Transfer failed.

host -l ZONE ipa-server
; Transfer failed.
Using domain server:
Name: ipa-server
Address: <IP>#53
Aliases: 

Host ZONE not found: 9(NOTAUTH)
; Transfer failed.




Expected results:
The zone to transfer


Additional info:
I also tried with 'also-notify' with the same result.  There seemed to have been some discussion on this issue on https://www.redhat.com/archives/freeipa-users/2011-June/msg00150.html, but I could not find an open bug.

Comment 2 Dmitri Pal 2011-12-11 19:03:27 UTC
Seems like a dup to me...

*** This bug has been marked as a duplicate of bug 733371 ***

Comment 3 Brian J. Atkisson 2011-12-12 14:29:43 UTC
> Seems like a dup to me...
> 
> *** This bug has been marked as a duplicate of bug 733371 ***

I don't think this is a duplicate of bz 733371.  This particular issue applies to the global setting in /etc/named.conf for zone xfers.  733371 deals with zone-level transfer settings.

Comment 4 Martin Kosek 2011-12-13 08:39:55 UTC
I think Dmitri is right. The ability to do zone transfer very much depends on bind-dyndb-ldap ability to allow and execute the zone transfer them.

Adam, can you please confirm that this bug actually depends on Bug 733371 and that allowing the zone transfers in the LDAP (idnsZoneTransfer attribute) fix this?

Comment 5 Adam Tkac 2011-12-13 10:52:40 UTC
(In reply to comment #4)
> I think Dmitri is right. The ability to do zone transfer very much depends on
> bind-dyndb-ldap ability to allow and execute the zone transfer them.
> 
> Adam, can you please confirm that this bug actually depends on Bug 733371 and
> that allowing the zone transfers in the LDAP (idnsZoneTransfer attribute) fix
> this?

Bug #733371 is not related to this. Bug #733371 is about zone transfer ACLs and this bug is about zone transfer itself. Although the plugin allows to set zone transfer ACLs, it doesn't have support for zone transfer itself.

Comment 13 Petr Spacek 2012-03-23 14:33:13 UTC
Zone transfer requires correct SOA serial number.

There is a SOA serial number specific bug: https://bugzilla.redhat.com/show_bug.cgi?id=805871

Comment 14 Petr Spacek 2012-05-09 10:41:10 UTC
Is it acceptable to have SOA serial numbers only locally significant? (I.e. each DNS master (= IPA server with DNS) will have different SOA serial number for given zone.)

In multi-master replicated environment is really hard to maintain single SOA serial number on each server in zone.

The related discussion is on freeipa-devel list: https://www.redhat.com/archives/freeipa-devel/2012-May/msg00047.html

Thanks for you time.

Comment 16 Gowrishankar Rajaiyan 2012-05-24 23:35:19 UTC
Verified: ipa-server-2.2.0-15.el6.x86_64

Comment 18 Brian J. Atkisson 2012-05-25 15:51:26 UTC
Hrm I replied on 5/9 and don't see the answer posted to bugzilla.  In any case:


> Is it acceptable to have SOA serial numbers only locally significant? (I.e.  each DNS master (= IPA server with DNS) will have different SOA serial number for given zone.)

This would cause problems for non-IPA slaves performing zone transfer.
All the serial numbers should be in sync across the IPA masters.

For example, in a corporate environment, where they maybe one department
using plain bind to host lab zones from corporate IT running IPA 
Different labs will have different zone versions based upon those labs
pointing to regional IPA servers.  

Also, it would be problematic in environments where a plain old Bind server does zone transfers from IPA servers in a fail-over/load-balanced config.

Comment 19 Petr Spacek 2012-05-28 10:45:42 UTC
(In reply to comment #18)
> Hrm I replied on 5/9 and don't see the answer posted to bugzilla.  In any
> case:
> 
> 
> > Is it acceptable to have SOA serial numbers only locally significant? (I.e.  each DNS master (= IPA server with DNS) will have different SOA serial number for given zone.)
> 
> This would cause problems for non-IPA slaves performing zone transfer.
> All the serial numbers should be in sync across the IPA masters.
Of course, generally you are right. But IPA violates classical single-master DNS model and we search for some trade-offs. (For example RFC 5936 http://tools.ietf.org/html/rfc5936#section-3.1 says "don't do it".)
Question should be: "Is there real configuration where it matters?" 


> For example, in a corporate environment, where they maybe one department
> using plain bind to host lab zones from corporate IT running IPA 
> Different labs will have different zone versions based upon those labs
> pointing to regional IPA servers.
I'm probably missing something, I don't see the problem. Different IPA servers will serve same data (when LDAP replication settles down), only SOA serial number will be different. Each plain BIND will see and serve exactly same zone except serial number.


> Also, it would be problematic in environments where a plain old Bind server
> does zone transfers from IPA servers in a fail-over/load-balanced config.
Yes, I agree. It's known problem of "local SOA serial" approach. Is described configuration deployed anywhere? Probably this problem can be partially alleviated with "tree" of DNS slaves or something similar.

Comment 22 errata-xmlrpc 2012-06-20 13:51:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0837.html


Note You need to log in before you can comment on or make changes to this bug.