Bug 76627 - wrong handling of "obsoletes" cyclus
Summary: wrong handling of "obsoletes" cyclus
Status: CLOSED DUPLICATE of bug 75794
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
high
high
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 11:52 UTC by Michael Stefaniuc
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 14:22:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Stefaniuc 2002-10-24 11:52:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
In Red Hat Linux 7.2 and 7.3 there is a cyclic obsoletes chain: gated obsoletes
zebra and zebra obsoletes gated. up2date -u (up2date-2.8.39-1.7.2 and
up2date-2.8.39-1.7.3) replaces zebra with gated and the next up2date -u run will
replace gated with zebra and a new cyclus can start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install zebra (or gated)
2. run "up2date -u"
3. and again "up2date -u"
	

Actual Results:  Each up2date -u run will switch between gated and zebra

Expected Results:  The obsoletes cyclus should be detected and no replacement
should take place.

Additional info:

Comment 1 Mihai Ibanescu 2002-10-25 14:25:18 UTC
This has been fixed server-side - gated and zebra should no longer obsolete each
other.

*** This bug has been marked as a duplicate of 75794 ***


Note You need to log in before you can comment on or make changes to this bug.