Bug 76629 - package exceptions dosn't work for obsoleted packages
package exceptions dosn't work for obsoleted packages
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 08:08 EDT by Michael Stefaniuc
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 01:01:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stefaniuc 2002-10-24 08:08:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Due to bugs #76626 and #76627 (gated obsoletes zebra and zebra obsoletes gated)
I added "zebra*" to the package exceptions list, but this had no effect and
zebra was replaced by gated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install zebra
2. add "zebra*" to the package exceptions list
3. run "up2date -u"
	

Actual Results:  zebra is replaced by gated.

Expected Results:  zebra shouldn't be replaced.

Additional info:

Adding also "gated*" to the package exception list prevents zebra from being
replaced, but this is only a workaround.
There is no way to know what package will obsolete in the future an other
package and put that also in the exceptions list.
Comment 1 Michael Stefaniuc 2002-10-24 08:41:16 EDT
I see i forgot the up2date versions: up2date-2.8.39-1.7.2 and up2date-2.8.39-1.7.3
Comment 2 Adrian Likins 2003-01-15 01:01:47 EST
This should be fixed in later versions by two
things:

   support for "blacklisting" bad obsoletes like the
   zebra<->gated circle

   close attention to the skip list in these cases

Note You need to log in before you can comment on or make changes to this bug.