Bug 76631 - "Lost connection to MySQL server during query" error since updating glibc
"Lost connection to MySQL server during query" error since updating glibc
Status: CLOSED DUPLICATE of bug 75128
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 08:13 EDT by Neil Sedley
Modified: 2007-04-18 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-06 20:43:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Sedley 2002-10-24 08:13:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
Since updating glibc (via up2date) I get a "Lost connection to MySQL server 
during query" when trying to connect via an external IP (localhost is ok). 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mysql -p -h<external ip>
2. enter password

the above from another hosts sometimes works and sometimes crashes
	

Actual Results:  "Lost connection to MySQL server during query" error and 
return to command prompt

This error is returned using mysql and mysqladmin and occurs before any query 
takes place. When this occurs the mysql server crashes and restarts with the 
following log message

Number of processes running now: 1
mysqld process hanging, pid 7258 - killed
021021 16:24:11  mysqld restarted
/usr/libexec/mysqld: ready for connections


Expected Results:  I expect to get a mySQL command prompt.

Additional info:

RPMs installed

mysql-3.23.41-1
mysql-devel-3.23.41-1
mysqlclient9-3.23.22-6
mysql-server-3.23.41-1
Comment 1 Tomas Edwardsson 2002-10-28 10:02:41 EST
This is also a problem with RedHat 8.0, no connections using IP numbers other 
than 127.0.0.1 work. If I try -h<IP of machine> it will fail and the following 
echoed into mysqld.log: 
 
Number of processes running now: 1 
mysqld process hanging, pid 15240 - killed 
021028 15:01:21  mysqld restarted 
 
I tried turning of this check alone in safe_mysqld and all that did for me was 
leaving the client session hanging.
Comment 2 Ken Snider 2002-10-29 17:44:16 EST
I can verify this as well.

As of our update to glibc 2.2.4-30, any DNS query will kill mysql.

Placing the offending IP in /etc/hosts *does* work as a temporary workaround,
but it appears any attempt by mySQL to do a DNS query kills the server.
Comment 3 Need Real Name 2002-11-05 04:23:50 EST
problem exists on RedHat 7.3 as well. Haven't check redhat 7.2
Comment 4 Eric Doutreleau 2002-11-05 11:02:13 EST
it appears that the nscd daemon is dead.

when i manually restart the nscd daemon it work again without
the /etc/hosts until the nscd daemon crashed
Comment 5 Ken Snider 2002-11-05 11:51:54 EST
It's not nscd specific - our systems don't run with nscd yet we see this problem. 

This affects any of our boxen (RH 7.1, 7.2, 7.3) using mysql if mysql needs to
access DNS for any reason. If we do not add the ip to /etc/hosts, mysql will crash.
Comment 6 Need Real Name 2002-11-06 20:43:42 EST
I believe this is a duplicate of Bug 75128 for which an Errata was released today.
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75128
Comment 7 Neil Sedley 2002-11-07 03:15:06 EST

*** This bug has been marked as a duplicate of 75128 ***

Note You need to log in before you can comment on or make changes to this bug.