Bug 76635 - manually running rpm -ivh or -Uvh will hang once every 20 installs
manually running rpm -ivh or -Uvh will hang once every 20 installs
Status: CLOSED DUPLICATE of bug 73200
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 08:54 EDT by David
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-24 08:58:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
plain text output from gdb using bt and then stepi commands after attaching to the process (930 bytes, text/plain)
2002-10-24 08:55 EDT, David
no flags Details
text/plain dump of alot of info about my machine (14.87 KB, text/plain)
2002-10-24 08:58 EDT, David
no flags Details

  None (edit)
Description David 2002-10-24 08:54:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
As I am using rpm to install additional packages rpm will hang after trying to
install a number of time (anywhere from 5 to 10).
The install gets to 100% on the # marks but hangs before returning to the
command line.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Install multiple rpm packages using rpm -Uvh package-name.rpm
2. rpm hangs befroe returning to the command line
3. kill rpm and try to rpm --rebuilddb which also hangs
	

Additional info:

I do use USB mass storage. 2 units
I have had a filesystem issue following using these units twice now.
fsck was able to fix the problems but some files were affected. I have reloaded
the affected files and everything seems to be OK.
I am not sure if this has impacted rpm at all.
I have since reloaded rpm by installing the rpm again over the existing package.
This has not helped with this issue.

Basically I either have a problem with USB storage, rpm or both.
My rpm problem seems to be reasonably reproducable at the moment so I thought I
would file a bug.
Comment 1 David 2002-10-24 08:55:49 EDT
Created attachment 81925 [details]
plain text output from gdb using bt and then stepi commands after attaching to the process
Comment 2 David 2002-10-24 08:58:15 EDT
Created attachment 81926 [details]
text/plain dump of alot of info about my machine
Comment 3 Jeff Johnson 2002-10-25 11:46:35 EDT
Hmmm, you appear to be killing rpm prematurely
on upgrade, this is bugzilla #73200.

If you do kill rpm with -9, you will have to do
	rm -f /var/lib/rpm/__db*
That should remedy the subsequent hangs.

*** This bug has been marked as a duplicate of 73200 ***

Note You need to log in before you can comment on or make changes to this bug.