Bug 766528 - Mount options not respected for guestmount
Mount options not respected for guestmount
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 04:37 EST by Mark Olliver
Modified: 2013-09-09 03:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-12 10:20:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Olliver 2011-12-12 04:37:37 EST
Description of problem:
If i give guestmount a set of mount options these are not respected and instead it mount the filesystem as follows:
guestmount on /mnt/guest_snapshot type fuse.guestmount (rw,nosuid,nodev)

I had tried:
 guestmount -a /dev/images/autest -m /dev/sda1:/:defaults,noatime /mnt/guest_snapshot

Which for my other file systems if mounting a normal disk then I get /dev/sda1 on / type ext4 (rw,noatime,errors=remount-ro)


Version-Release number of selected component (if applicable):
guestmount 1.15.10 - using development GIT checkout from last week.

How reproducible:
100%

Steps to Reproduce:
1. guestmount -a /dev/images/autest -m /dev/sda1:/:defaults,noatime /mnt/guest_snapshot
2. mount
  
Actual results:
guestmount on /mnt/guest_snapshot type fuse.guestmount (rw,nosuid,nodev)

Expected results:
guestmount on /mnt/guest_snapshot type fuse.guestmount (rw,noatime,errors=remount-ro)

Additional info:
Comment 1 Richard W.M. Jones 2011-12-12 05:21:52 EST
I think this might be controlled by FUSE itself.  Did
you have a look at 'guestmount --fuse-help' output?
Comment 2 Richard W.M. Jones 2011-12-12 08:43:43 EST
Mark, since you fixed this with a guestmount FUSE option,
could you summarise how it was fixed here and close the bug.
This ensures there is a record for other users.
Comment 3 Mark Olliver 2011-12-12 09:24:29 EST
I fixed this by adding a '-o' to the guestmount command, this then allowed the mount to process correctly.

guestmount -a /dev/images/autest -m /dev/sda1 /mnt/guest_snapshot -o noatime,dev,sync
Comment 4 Richard W.M. Jones 2011-12-12 10:21:43 EST
Interesting, I didn't know you could use 'ordinary' mount
options there.  I thought it was limited to FUSE options,
so you learn something new every day.
Comment 5 Gabriel Kerneis 2013-09-09 03:00:28 EDT
After some trial and error, I can confirm that using "-o dev" works (e.g.), but only if you call guestmount as root. Otherwise, the options are ignored are even rejected with an error message.

Note You need to log in before you can comment on or make changes to this bug.