Bug 766611 - [289c2902d6a81f7a5b6da04c24cc955bd5427178] errors doing setxattr when running dbench
[289c2902d6a81f7a5b6da04c24cc955bd5427178] errors doing setxattr when running...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Junaid
Vijaykumar Koppad
:
: 765498 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-12-12 07:55 EST by Rahul C S
Modified: 2015-12-01 11:45 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: release-3.3
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2011-12-12 07:55:54 EST
Description of problem:
while running dbench with options "-s -F -S --stat-check 10" seeing a lot of no such file or directory errors while doing setxattr on all bricks.

logs:
[2011-12-12 17:17:50.438084] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client4/~dmtmp/PM/EVENTS.DOC failed: No such file or directory
[2011-12-12 17:17:50.448873] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client1/~dmtmp/WORD/CHAP10.DOC failed: No such file or directory
[2011-12-12 17:17:50.463965] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client3/~dmtmp/ACCESS/FASTENER.MDB failed: No such file or directory
[2011-12-12 17:17:50.483308] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client7/~dmtmp/PM/MOVED.DOC failed: No such file or directory
[2011-12-12 17:17:50.509644] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client0/~dmtmp/PM/EVENTS.DOC failed: No such file or directory
[2011-12-12 17:17:50.528459] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client9/~dmtmp/ACCESS/FASTENER.MDB failed: No such file or directory
[2011-12-12 17:17:50.537307] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client1/~dmtmp/PM/MOVED.DOC failed: No such file or directory
[2011-12-12 17:17:50.547092] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client5/~dmtmp/ACCESS/FASTENER.MDB failed: No such file or directory
[2011-12-12 17:17:50.574301] E [posix-helpers.c:601:posix_handle_pair] 0-vol-posix: setxattr on /data/export2/clients/client7/~dmtmp/ACCESS/FASTENER.MDB failed: No such file or directory

Version-Release number of selected component (if applicable):


How reproducible:
Frequent

Steps to Reproduce:
1. Created a distributed replicate volume 3x2.
2. enabled quota, gsync & stat-prefetch
3. ran dbench -s -F -S --stat-check 10 from single client
  
Actual results:
glusterfs logging as setxattr failed because of no file.

Expected results:
since dbench is running and the file exists there should be no such errors.

Additional info:
Comment 1 Junaid 2012-04-05 05:03:37 EDT
*** Bug 765498 has been marked as a duplicate of this bug. ***
Comment 3 Junaid 2012-04-13 07:29:23 EDT
http://review.gluster.com/#change,3105 fixes the problem.
Comment 4 Vijaykumar Koppad 2012-06-03 07:28:17 EDT
I still get these logs in brick-log file with 3.3.0qa45 


[2012-06-03 05:09:19.600482] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client3/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.625291] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client9/~dmtmp/SEED/LARGE.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.634638] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/~dmtmp/ACCESS/FASTENER.MDB: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.655013] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client2/~dmtmp/SEED/SMALL.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.669228] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client5/filler.000: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.676337] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client2/~dmtmp/SEED/MEDIUM.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.680335] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client9/filler.002: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.695658] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client5/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.708250] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client2/~dmtmp/SEED/LARGE.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.714519] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client9/filler.003: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.725587] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/~dmtmp/SEED/SMALL.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.737666] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client0/filler.000: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.745927] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client9/filler.004: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.757850] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/~dmtmp/SEED/MEDIUM.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.762042] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client2/filler.000: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.766865] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client0/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.778100] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/~dmtmp/SEED/LARGE.FIL: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.780929] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client7/filler.000: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.782474] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client2/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.799742] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client7/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.811169] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/filler.000: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
[2012-06-03 05:09:19.831307] E [posix-helpers.c:685:posix_handle_pair] 0-doa-posix: /exportdir/d1/clients/client8/filler.001: key:trusted.glusterfs.9e357e40-5f66-4630-ae5d-5fca10972134.xtime error:No such file or directory
Comment 6 Vijaykumar Koppad 2012-06-12 04:33:08 EDT
http://review.gluster.com/#change,3514 , this patch fixes this bug.

Note You need to log in before you can comment on or make changes to this bug.