Bug 766697 - running configure -p rhevm without updating rhevm config needs better error msg
Summary: running configure -p rhevm without updating rhevm config needs better error msg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: John Eckersberg
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-12 15:15 UTC by Dave Johnson
Modified: 2012-05-15 20:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:45:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0586 normal SHIPPED_LIVE new packages: aeolus-configure 2012-05-15 22:31:34 UTC

Description Dave Johnson 2011-12-12 15:15:39 UTC
Description of problem:
================================

If you run 'aeolus-cionfigure -p rhevm' without updating the rhevm configuration in /etc/aeolus-configure/nodes/rhevm, you get the following error which does not point back to the fact that the issue is /etc/aeolus-configure/nodes/rhevm needs to be updated.

Error:
Failed to parse template aeolus/rhevm.json: Could not find value for 'rhevm_deltacloud_username' at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm.pp:17 on node qeblade29.rhq.lab.eng.bos.redhat.com

Comment 1 wes hayutin 2011-12-15 16:46:38 UTC
should be vsphere as well..

Comment 2 John Eckersberg 2011-12-22 21:08:14 UTC
commit 6ec3cad20dfebd932ce52889a1756f115c1ca90c
Author: John Eckersberg <jeckersb@redhat.com>
Date:   Thu Dec 22 15:00:32 2011 -0500

    BZ#766697 - running configure -p rhevm without updating rhevm config needs better error msg
    
    https://bugzilla.redhat.com/show_bug.cgi?id=766697
    
    This adds a new parser function to ensure a list of variable names is
    defined.  This function is in turn used by the rhevm and vsphere
    profiles to make sure all required config parameters are set,
    otherwise failing with a sane error message.

Comment 3 Shveta 2012-01-05 13:14:10 UTC
[root@dell-pe1950-03 ~]# aeolus-configure -p rhevm
Launching aeolus configuration recipe...
Missing required parameter rhevm_nfs_server in /etc/aeolus-configure/nodes/rhevm_configure at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm.pp:25 on node dell-pe1950-03.rhts.englab.brq.redhat.com


=================================================

[root@dell-pe1950-03 ~]# aeolus-configure -p vsphere
Launching aeolus configuration recipe...
Missing required parameter vsphere_deltacloud_provider in /etc/aeolus-configure/nodes/vsphere_configure at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/vsphere.pp:23 on node dell-pe1950-03.rhts.englab.brq.redhat.com


============================================================

Verified in 

 rpm -qa|grep aeolus
aeolus-conductor-daemons-0.8.0-0.20111222233342gitd98cb57.el6.noarch
aeolus-configserver-0.4.5-1.el6.noarch
rubygem-aeolus-image-0.3.0-0.20111222173411gitc13b654.el6.noarch
rubygem-aeolus-cli-0.3.0-0.20111222173356git3cd6277.el6.noarch
aeolus-all-0.8.0-0.20111222233342gitd98cb57.el6.noarch
aeolus-conductor-0.8.0-0.20111222233342gitd98cb57.el6.noarch
aeolus-configure-2.5.0-0.20120104154940git196b80d.el6.noarch
aeolus-conductor-doc-0.8.0-0.20111222233342gitd98cb57.el6.noarch

Comment 4 wes hayutin 2012-01-12 16:16:36 UTC
bugs in verified or on_qa moving off tracker

Comment 6 errata-xmlrpc 2012-05-15 20:45:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html


Note You need to log in before you can comment on or make changes to this bug.