Bug 76671 - Backing store broken on Radeon & Rage 128
Backing store broken on Radeon & Rage 128
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 15:25 EDT by Ian Romanick
Modified: 2007-03-26 23:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:44:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested Config file (2.65 KB, text/plain)
2002-11-03 11:17 EST, Michael Breuer
no flags Details

  None (edit)
Description Ian Romanick 2002-10-24 15:25:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
Backing store on Radeon (R100 & M6 tested) and Rage 128 (Rage 128 Pro tested)
cards does not work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start X w/+bs (i.e., /usr/X11R6/bin/X +bs)
2.Run twm with no config file (default on RH 7.3).
3.Left click the mouse to bring up the twm menu.
	

Actual Results:  The menu is blank.  Move the mouse over the menu items and they
will magically appear.  

Expected Results:  The text should have been displayed in the menu to begin with.

Additional info:

I have tested this on Matrox G400 & S3 Savage IX (IBM T21 laptop)hardware and
the text is correctly displayed in the menu.
Comment 1 Ian Romanick 2002-10-25 18:01:40 EDT
I just tried to reproduce this bug on a Mobility 7500 using RH 8.0
(XFree86-4.2.0-72), and twm worked correctly.  There must be some patch that's
in that RPM that isn't in the older 7.3 RPM *or* in XFree86 CVS.
Comment 2 Michael Breuer 2002-10-28 16:13:26 EST
I can recreate this problem on 4.2.0-72 on a Compaq Evo n410c laptop with RH 8.0.

Note: Acceleration must be enabled for the problem to occur.  My guess is that
the 4.2.0-72 build on which the problem did not occur had acceleration disabled
for some reason.
Comment 3 Mike A. Harris 2002-11-03 07:06:49 EST
Please attach config file and log file from non-working configuration.
Comment 4 Michael Breuer 2002-11-03 11:17:08 EST
Created attachment 83344 [details]
Requested Config file
Comment 5 Michael Breuer 2002-11-03 11:18:33 EST
Note: The problem can be recreated with a default RH 8.0 install... just turn on
backing store (see attached file).

Note: setting the AGP parameters has no bearing on this problem... but may
contribute to the well-documented VT Switch issue.
Comment 6 Ian Romanick 2002-11-05 15:35:27 EST
Kevin E. Martin posted a fix for this problem to the dri-devel list today.  The
fix is to move two lines of code in
programs/Xserver/hw/xfree86/ati/radeon_driver.c.  In the DRI CVS, the fixed
version of the file 1.46.  I have verified that these changes fix the problem.

Will updated RPMs be available soon? :)
Comment 7 Mike A. Harris 2002-11-13 23:36:31 EST
Yes, it is in X CVS and will get picked up during my next CVS update.

Thanks.
Comment 8 Mike A. Harris 2002-11-22 01:18:30 EST
Fixed in rawhide XFree86 build for today.  Changing bug state to
MODIFIED.  Please confirm fix and close to RAWHIDE, or if problem
is still present, change back to ASSIGNED, and include any new details.
Comment 9 Mike A. Harris 2002-11-22 03:16:03 EST
Oh, by the way... If someone tests this and lets me know that it works,
I can backport it for 7.3 also.

Note You need to log in before you can comment on or make changes to this bug.