Bug 766714 - Fix Jabra SPEAK 410 USB audio playback (with patch!)
Fix Jabra SPEAK 410 USB audio playback (with patch!)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 10:31 EST by Richard W.M. Jones
Modified: 2012-11-08 20:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 05:15:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Jabra_SPEAK_410_USB-1-3-0.dfu (847.06 KB, application/octet-stream)
2011-12-16 04:54 EST, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2011-12-12 10:31:24 EST
Description of problem:

It'd be cool if someone could nurse this patch upstream:
https://lkml.org/lkml/2011/12/10/88

It fixes audio playback on Jabra SPEAK 410 USB, a rather high-end
conference phone (costs about $130).

The patch reveals some fundamental problem with Linux USB
descriptor/endpoint parsing in general, although maybe the
Jabra device isn't properly following the USB spec correctly.

Version-Release number of selected component (if applicable):

Linux 3.2

How reproducible:

100%

Steps to Reproduce:
1. paplay /path/to/foo.wav
2. Play with pavucontrol so that output is supposed to be coming from the Jabra device.
3.
  
Actual results:

No sound.

Expected results:

When you apply the patch ... sound plays fine.

Additional info:
Comment 1 Richard W.M. Jones 2011-12-16 04:54:02 EST
Created attachment 547703 [details]
Jabra_SPEAK_410_USB-1-3-0.dfu

Jabra sent us the attached firmware update which is supposed
to fix this issue, so (assuming it works) the patch would no longer
be necessary.  Note that a Windows tool from jabra.com/pcsuite is
required to apply this.
Comment 2 Richard W.M. Jones 2011-12-16 05:15:18 EST
The firmware update seems to have fixed the audio playback
problem, although at least two of the USB descriptors are still
in the wrong order ...
Comment 3 Gideon Mayhak 2012-06-30 20:54:00 EDT
I just wanted to comment on this bug that I am experiencing the same issue in F17 with a Jabra SPEAK 410 that just came in the mail, so it seems at least some places are still shipping units without updated firmware.

I am going to get it connected to a Windows PC tonight or tomorrow and try updating the firmware, at which point I expect it will work.  However, since this is a bug that still seems to be present in shipping devices, and since a Windows machine is currently required to fix it, do you think it might be worth pursuing getting this patch into mainline anyway?  Does it have any negative side effects when using with a device with the updated firmware?
Comment 4 Richard W.M. Jones 2012-07-02 03:28:24 EDT
(In reply to comment #3)
> I am going to get it connected to a Windows PC tonight or tomorrow and try
> updating the firmware, at which point I expect it will work.  However, since
> this is a bug that still seems to be present in shipping devices, and since
> a Windows machine is currently required to fix it, do you think it might be
> worth pursuing getting this patch into mainline anyway?

No, the patch is wrong and shouldn't go upstream.  The correct
fix is to get Jabra to start shipping updated firmware.
Comment 5 Gideon Mayhak 2012-07-02 17:22:08 EDT
Okay.  Thanks for the update.  I was able to update my firmware, and it is working great now.  Interestingly, Jabra's own firmware update tool only offered 1.0.0 from their server, my device shipped with 1.1.0, and the firmware file you provided was 1.3.0.  So you do need to download the firmware from this bug and then point their firmware updater to that file.
Comment 6 Aron Griffis 2012-11-08 20:07:14 EST
This bugzilla showed up first when I googled "jabra 410 linux", and because of this I knew to update the firmware to make it work. Thanks! By the way, the current version from the Jabra site is now 1.0.8

Note You need to log in before you can comment on or make changes to this bug.