Bug 76672 - expat 1.95.4 entities bug: in particular XML::Twig won't work
expat 1.95.4 entities bug: in particular XML::Twig won't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: expat (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 16:09 EDT by Ed Avis
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-24 16:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2002-10-24 16:09:37 EDT
The 1.95.5 release of expat fixes many bugs present in 1.95.4.  One such bug is
in entity handling and prevents the popular Perl module XML::Twig from installing.

How to reproduce: get the latest XML::Twig tarball from CPAN, do perl
Makefile.PL and make test.  Two of the tests will fail.  They do not fail with
versions earlier than 1.95.4 of libexpat, and they do not fail with the latest
version 1.95.5.  This is known to be a bug in expat 1.95.4.

(advocacy follows, skip if necessary)

I don't know whether you consider it worth the effort to produce an erratum
package for expat but since 1.95.5 is a pure bugfix release it seems reasonable.
 The maintainer of expat says:

  'This release of Expat fixes a number of bugs, mostly minor, but annoying when
you hit them. Some caused memory access violations, so if you've been using
1.95.4, it's probably worth updating.'
Comment 1 Jeff Johnson 2002-11-12 10:59:47 EST
Fixed in expat-1.95.5-1.

Note You need to log in before you can comment on or make changes to this bug.