Bug 766806 - invalid syntax in /usr/share/dstat/dstat_mysql5_conn.py
invalid syntax in /usr/share/dstat/dstat_mysql5_conn.py
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dstat (Show other bugs)
6.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Tomas Dolezal
: FastFix, Patch
Depends On:
Blocks: 1356056
  Show dependency treegraph
 
Reported: 2011-12-12 11:20 EST by Jiri Popelka
Modified: 2017-03-21 05:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: dstat-0.7.0-3.el6
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 05:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (712 bytes, patch)
2011-12-12 11:22 EST, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Jiri Popelka 2011-12-12 11:20:51 EST
Building dstat package on RHEL-6.2 shows:

/usr/lib/rpm/brp-python-bytecompile
Compiling /home/jpopelka/rpmbuild/BUILDROOT/dstat-0.7.0-2.el6.x86_64/usr/share/dstat/dstat_mysql5_conn.py ...
SyntaxError: ('invalid syntax', ('/usr/share/dstat/dstat_mysql5_conn.py', 39, 74, "                self.set2['Threads'] = float(thread[1] / float(max[1]) 1.0 * 100)\n"))


Additional info:
I don't know whether this could influence how the mysql5 plugin works but it's certainly a regression because I don't see such a problem on RHEL-6.1
Comment 1 Jiri Popelka 2011-12-12 11:22:12 EST
Created attachment 545822 [details]
Patch
Comment 3 Suzanne Yeghiayan 2012-02-14 18:24:11 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 RHEL Product and Program Management 2012-09-07 01:01:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Akemi Yagi 2014-05-31 20:17:14 EDT
This issue is now reported in the CentOS bug tracker:

http://bugs.centos.org/view.php?id=7142
Comment 16 errata-xmlrpc 2017-03-21 05:34:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0619.html

Note You need to log in before you can comment on or make changes to this bug.