Bug 766936 - [abrt] system-config-date-1.9.67-1.fc16: __init__.py:52:_init:RuntimeError: could not open display
Summary: [abrt] system-config-date-1.9.67-1.fc16: __init__.py:52:_init:RuntimeError: c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:44dad3ed2a40d9c18cbe586456d...
: 870692 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-12 20:11 UTC by Michal Jaegermann
Modified: 2013-01-12 15:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-03 07:28:45 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2011-12-12 20:11:03 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        /usr/bin/python /usr/share/system-config-date/system-config-date.py
comment:        Just tried to change system data from a "System Settings" GUI while logged on a desktop.  I was asked for a password and after that got only a blink of a crashing configurator.
executable:     /usr/share/system-config-date/system-config-date.py
kernel:         3.1.4-1.fc16.x86_64
reason:         __init__.py:52:_init:RuntimeError: could not open display
time:           Sun 11 Dec 2011 06:49:38 PM MST
uid:            0
username:       root

backtrace:
:__init__.py:52:_init:RuntimeError: could not open display
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-date/system-config-date.py", line 73, in <module>
:    useGuiMode(page)
:  File "/usr/share/system-config-date/system-config-date.py", line 46, in useGuiMode
:    import scdMainWindow
:  File "/usr/share/system-config-date/scdMainWindow.py", line 30, in <module>
:    import gtk
:  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
:    _init()
:  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
:    _gtk.init_check()
:RuntimeError: could not open display
:
:Local variables in innermost frame:
:sys: <module 'sys' (built-in)>
:sys_path: ['/usr/share/system-config-date', '/usr/lib64/python27.zip', '/usr/lib64/python2.7', '/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', '/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', '/usr/lib64/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/PIL', '/usr/lib64/python2.7/site-packages/gst-0.10', '/usr/lib64/python2.7/site-packages/gtk-2.0', '/usr/lib/python2.7/site-packages', '/usr/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info']

Comment 1 Jose Mendoza 2012-05-30 18:52:19 UTC
I unplugged the live display and reconnected to add a new display and could not see the desktop. I had to reboot to get Display back on.

Package: system-config-date-1.9.67-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 2 Nils Philippsen 2012-12-10 13:47:26 UTC
The problem you had is two-fold:

1) The display not being available: There is nothing system-config-date (or any other GUI program) can do about it.
2) Raising an exception instead of printing an error message onto the terminal. I'll fix that upstream shortly, and then in an updated Fedora package.

Comment 3 Nils Philippsen 2012-12-10 13:50:53 UTC
Ah, forgot: re 1) you might want to open a bug against some component of your desktop.

Comment 4 Nils Philippsen 2012-12-10 13:52:22 UTC
*** Bug 870692 has been marked as a duplicate of this bug. ***

Comment 5 Michal Jaegermann 2012-12-10 16:58:18 UTC
(In reply to comment #2)
> The problem you had is two-fold:
> 
> 1) The display not being available: There is nothing system-config-date (or
> any other GUI program) can do about it.

The original report said: "... from a "System Settings" GUI while logged on a desktop".  A subsequent password dialog also required that display.  That means that system-config-date is not picking it up.  Moreover 'su -' from a terminal window opened from a desktop followed by 'system-config-date' does not have that problem and works.

Comment 6 Fedora Update System 2012-12-11 11:06:51 UTC
system-config-date-1.10.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-date-1.10.5-1.fc18

Comment 7 Fedora Update System 2012-12-11 11:12:06 UTC
system-config-date-1.10.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/system-config-date-1.10.5-1.fc16

Comment 8 Fedora Update System 2012-12-11 11:12:44 UTC
system-config-date-1.10.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-date-1.10.5-1.fc17

Comment 9 Fedora Update System 2012-12-11 20:06:58 UTC
Package system-config-date-1.10.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.10.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20194/system-config-date-1.10.5-1.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-01-03 07:28:46 UTC
system-config-date-1.10.5-1.fc16, python-slip-0.2.24-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-11 23:19:02 UTC
system-config-date-1.10.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-01-12 15:01:16 UTC
system-config-date-1.10.5-1.fc17, python-slip-0.2.24-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.