Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 76701 - Booting from install CD hangs at 'Partition Check'
Booting from install CD hangs at 'Partition Check'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 21:14 EDT by Grant McLean
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant McLean 2002-10-24 21:14:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
System was successfully running RH7.1.  I upgraded by booting from CDROM but the
boot process hung at the message:

  Partition check:
  hda:

When I booted with the 'ide=nodma' option everything worked and the upgrade was
successfull except that I then encountered the exact same problem booting from
the new kernel on the hard drive.

I read about the issue on this page:

  http://www.exocore.com/technologies/linux/rhl71dma/

and saw that RedHat would like to know which models of CDROM drive should be
blacklisted for not supporting DMA.  This is my model info:

$ cat /proc/ide/hdd/model
ASUS CD-S400/A

I have tried upgrading my motherboard BIOS to the latest available from ASUS but
the kernel still won't boot off the hard drive with DMA enabled - so I've
configured the option into grub.conf

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot without ide=nodma kernel option
	

Actual Results:  Kernel loads and displays various messages until it gets to:

Partition check:
hda

Then it sits there - I gave up waiting after 15 minutes

Expected Results:  The system should have booted

Additional info:
Comment 1 Bugzilla owner 2004-09-30 11:40:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.