This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 767034 - Migrate SysV script to support systemd at Fedora17
Migrate SysV script to support systemd at Fedora17
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
: Patch
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2011-12-12 21:56 EST by Marcelo Moreira de Mello
Modified: 2013-03-06 13:34 EST (History)
7 users (show)

See Also:
Fixed In Version: spacewalk-admin-1.9.4-1 osad-5.11.17-1 spacewalk-monitoring-1.9.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Silly first draft (283 bytes, application/octet-stream)
2012-01-16 08:42 EST, Pablo Hess
no flags Details
Unit file employing the "spacewalk-service" wrapper script (243 bytes, text/plain)
2012-01-16 13:38 EST, Pablo Hess
no flags Details

  None (edit)
Description Marcelo Moreira de Mello 2011-12-12 21:56:52 EST
Description of problem:
Migrate SysV script to support SystemD at Fedora17

Version-Release number of selected component (if applicable):
Fedora 16
  
Additional info:

http://fedoraproject.org/wiki/Features/SysVtoSystemd
Comment 1 Marcelo Moreira de Mello 2011-12-12 21:58:59 EST
Taking...
Comment 2 Pablo Hess 2012-01-16 08:42:16 EST
Created attachment 555507 [details]
Silly first draft
Comment 3 Pablo Hess 2012-01-16 13:38:22 EST
Created attachment 555570 [details]
Unit file employing the "spacewalk-service" wrapper script
Comment 4 Jan Pazdziora 2012-02-28 02:51:13 EST
I don't feel this unit file is correct.

Of course, if would be good if Marcelo could clarify the overall goal of this bugzilla but my understanding is that we need the services currently started via spacewalk-service to become first-class citizens to systemd, not spacewalk-service to become a systemd unit.
Comment 5 Pablo Hess 2012-02-28 11:16:54 EST
(In reply to comment #4)

> my understanding is that we need the services currently started
> via spacewalk-service to become first-class citizens to systemd, not
> spacewalk-service to become a systemd unit.

I agree with you.

I have a few unit files that try to do just that -- they're currently working fine on a Fedora 16 with Spacewalk. I'll upload them here ASAP (i.e. in a few hours).
Comment 6 Pablo Hess 2012-03-18 02:25:35 EDT
Just found out Lennart's solution (the best one so far) to this problem: lists.freedesktop.org/archives/systemd-devel/2012-January/004266.html

Our spacewalk unit does NOT have to be a .service at all; it's perfectly fine as a .target because Spacewalk is "just" a collection of dependencies.

I'll be implementing this solution soon in order to get Spacewalk its native systemd unit for Fedora 16 (hopefully).
Comment 8 Michael Mráka 2013-02-13 08:40:17 EST
Systemd stuff has been implemented in spacewalk nightly.

commit 53bfb8b997545f02fc7660fce4f7cf12615347ac
    pack serviced version of spacewalk-service on Fedoras
commit 20980f27f3ee76e87513250a67c3a76d2ae2b488
    added systemd version of spacewalk-service
commit f1bf06dc1772c6504d5ba41582d36d82fad04ac0
    start monitoring services with spacewalk target
commit 705016ea4bd0a30a4e723533ad038c186d6047e9
    systemd target for spacewalk
commit eff33eb16562a14b88436d7fa23bcbbd967c5979
    moved waiting for jabberd to helper
    to be reused for systemd
commit 6be15bef9c7b5f002056829badfbc8beca94c893
    moved ensure_httpd_down() into script
    so we can reuse it for systemd startup script
commit eaa71f1648035a07a845c8f149651c25edcaeda7
    moved wait-for-tomcat into general startup helper
commit fca0af8b597ea614385620dbb12d1e357414da18
    possibility to disable waiting for tomcat
commit 90c4c24115f9de654da34d52be40e0a0685c078c
    implemented wait for tomcat in systemd
commit 11af8d303c3e7a3cb9e325abf098c61abba14961
    added spacewalk-wait-for-tomcat to rpm
commit 47621445e52d0373dc49f584c2b107c0b51630c5
    moved wait-for-tomcat into script
commit 205eeb851140f9f160667057ec54e3785b95b4a2
    pack monitoring systemd stuff
commit 4f18111d98772e67c94e15817f0e402f6b8d2af0
    created systemd services for monitoring
commit 029f744b8f8097945ba7b17d3b8383167a097b3b
Comment 9 Stephen Herr 2013-03-01 12:07:01 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 10 Stephen Herr 2013-03-06 13:34:25 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.