Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 76704 - image viewer does not exist
image viewer does not exist
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 23:18 EDT by Florin Andrei
Modified: 2015-01-07 19:01 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.6.1-0.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 08:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2002-10-24 23:18:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
If you hit enter on an image, mc is supposed to run an image viewer.
However, the image viewers provided in the mc settings do not exist in Red Hat
default install.
The /usr/lib/mc/mc.ext file has to be modified to use one of the image viewers
that are provided in the distribution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run mc
2.go to an image file
3.hit enter
	

Actual Results:  mc says it cannot find ee

Expected Results:  mc should run an existing image viewer to view the image

Additional info:

This change to /usr/lib/mc/mc.ext makes mc happy:

--- mc.ext.bak  2002-10-24 20:13:05.000000000 -0700
+++ mc.ext      2002-10-24 20:13:22.000000000 -0700
@@ -237,7 +237,7 @@
        View=sxpm %f

 include/image-options
-       Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (ee %f &); fi
+       Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (eog %f &); fi
        View=%view{ascii} identify %f
        #View=%view{ascii} asciiview %f
        Set root window to this image=background-properties --setwallpaper %f &
Comment 1 Jindrich Novy 2004-10-29 08:22:45 EDT
Hi Florin,

this is fixed rawhide for rather long time. I decided to use display
as it knows almost everything and it's present in Red Hat releases.
The recent upstream version of mc uses gqview so the question is
whether we should keep gqview or convert to display (propose it upstream).

In my opinion I prefer display since it knows far more image formats
than gqview.

Florin, Leonard, Miloslav, your opinion?

Thanks for the report and patch,
Jindrich
Comment 2 Miloslav Trmac 2004-10-29 08:52:31 EDT
As far as I can tell, gqview is not shipped in Fedora Core any more,
so the answer is obvious.
Comment 3 Florin Andrei 2004-10-29 12:05:45 EDT
I really don't care which viewer is used as long as it's included by
default in Red Hat / Fedora, it's simple, lightweight and has fairly
good usability. It doesn't have to be a huge thing - viewers called
from shells are typically at a fairly trivial level w.r.t. the
functionality.

One thing though: whichever viewer is chosen, it would be nice to have
the ability to scale the image to the window size, if it's bigger.
That should be the default. Otherwise, it will be awkward to view
large images.
Other than that, the simpler the better.
Comment 4 Jindrich Novy 2004-11-01 05:14:11 EST
It is exactly what display does when the image won't fit the screen.
It adds a "pan icon" window which helps you to scroll within a large
image displayed in the second window, usualy covering the whole screen
and "pan icon" is always on top. I consider this as a better solution
than downsampling the image, you have this possibility in display though.

Note You need to log in before you can comment on or make changes to this bug.