Bug 767055 - Error when pull as XLIFF file format: Underlying stream encoding 'ASCII' and input paramter for writeStartDocument() method 'utf-8' do not match
Summary: Error when pull as XLIFF file format: Underlying stream encoding 'ASCII' and ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Maven   
(Show other bugs)
Version: 1.4.3-SNAPSHOT
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
: 2.3
Assignee: zanata-dev-internal
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-13 04:59 UTC by Ding-Yi Chen
Modified: 2013-11-27 03:36 UTC (History)
5 users (show)

Fixed In Version: 2.3-SNAPSHOT (20130304-0035)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 03:25:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 903964 None None None Never

Description Ding-Yi Chen 2011-12-13 04:59:46 UTC
Description of problem:
When pulling an XLIFF project, following error is shown:

[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:1.4.4-SNAPSHOT:pull (default-cli) on project null: Zanata mojo exception: Error generating XLIFF file format: Underlying stream encoding 'ASCII' and input paramter for writeStartDocument() method 'utf-8' do not match. -> [Help 1]

Version-Release number of selected component (if applicable):
Server: Zanata version 1.4.5-SNAPSHOT (20111212-1307). 
Client: 1.4.4-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1. Push the project Spacewalk (git://git.fedorahosted.org/spacewalk.git) in to zanata
2. Pull the project using maven client with:
mvn -B -e org.zanata:zanata-maven-plugin:push "-Dzanata.includes=**/StringResource_en_US.xml" -Dzanata.pushTrans

  
Actual results:
Failed with error

Expected results:
Pull successfully.

Additional info:

Comment 1 David Mason 2013-01-29 07:39:28 UTC
Similar error when running standard tests on Windows machine. Fixed for test, may also prevent this error.

See: https://github.com/zanata/zanata-common/commit/d7b8549bcbbbd934cb19abf2bfe98999ac4199f9

Comment 2 Ding-Yi Chen 2013-02-15 05:47:54 UTC
Tested with Zanata version 2.2-SNAPSHOT (20130215-1232)

It failed on document 
java/code/src/com/redhat/rhn/frontend/strings/java/StringResource 

with following cause:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:2.0.2-SNAPSHOT:push (default-cli) on project null: Zanata mojo exception: Failed while pushing document translations: [] -> [Help 1]                                                        
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.zanata:zanata-maven-plugin:2.0.2-SNAPSHOT:push (default-cli) on project null: Zanata mojo exception                                                                    
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)                                   
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)                                   
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)                                   
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)           
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)           
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.MojoExecutionException: Zanata mojo exception
        at org.zanata.maven.ConfigurableMojo.execute(ConfigurableMojo.java:133)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
        ... 19 more
Caused by: java.lang.RuntimeException: Failed while pushing document translations: []
        at org.zanata.client.commands.push.PushCommand.pushTargetDocToServer(PushCommand.java:576)
        at org.zanata.client.commands.push.PushCommand.access$100(PushCommand.java:52)
        at org.zanata.client.commands.push.PushCommand$1.visit(PushCommand.java:392)
        at org.zanata.client.commands.push.XliffStrategy.visitTranslationResources(XliffStrategy.java:86)
        at org.zanata.client.commands.push.PushCommand.pushCurrentModule(PushCommand.java:385)
        at org.zanata.client.commands.push.PushCommand.run(PushCommand.java:205)
        at org.zanata.maven.ConfigurableMojo.runCommand(ConfigurableMojo.java:158)
        at org.zanata.maven.AbstractPushPullMojo.runCommand(AbstractPushPullMojo.java:35)
        at org.zanata.maven.ConfigurableMojo.execute(ConfigurableMojo.java:129)
        ... 21 more

Comment 3 Sean Flanigan 2013-02-17 23:52:57 UTC
This is another example of async push not returning error messages to the client.  Carlos, do we have a bug for that?

Comment 4 Carlos Munoz 2013-02-18 03:29:18 UTC
Yes, it's bug 903964.

Comment 5 Sean Flanigan 2013-02-19 00:18:39 UTC
Ding, could you please try this again, and check the server-side error log?

Comment 6 Ding-Yi Chen 2013-03-04 05:59:13 UTC
Seems this error has been fixed.

VERIFIED with  Zanata version 2.3-SNAPSHOT (20130304-0035)
maven client 2.2.1-SNAPSHOT

Comment 7 Sean Flanigan 2013-11-27 03:16:00 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 8 Sean Flanigan 2013-11-27 03:17:05 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 9 Sean Flanigan 2013-11-27 03:19:15 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 10 Sean Flanigan 2013-11-27 03:25:18 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 11 Sean Flanigan 2013-11-27 03:33:57 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 12 Sean Flanigan 2013-11-27 03:36:10 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.


Note You need to log in before you can comment on or make changes to this bug.