Bug 767167 - Programmable completion contains syntax error
Summary: Programmable completion contains syntax error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bzr
Version: el5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-13 12:52 UTC by Kamae Norihiro
Modified: 2011-12-29 22:00 UTC (History)
2 users (show)

Fixed In Version: bzr-2.1.4-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-29 22:00:36 UTC
Type: ---


Attachments (Terms of Use)

Description Kamae Norihiro 2011-12-13 12:52:39 UTC
Description of problem:
When logging in, bash shows a syntax error message.

Version-Release number of selected component (if applicable):
 bzr-2.1.4-1.el5.x86_64
 bash-3.2-32.el5.x86_64

How reproducible:
 Always bash sources /etc/bash_completion.d/bzr.

Steps to Reproduce:
1. install bzr-2.1.4-1.el5.x86_64
2. log in with a user whose login-shell is bash
or,
1. run a command below in bash
 $ source /etc/bash_completion.d/bzr

Actual results:
-bash: /etc/bash_completion.d/bzr: line 29: syntax error in conditional expression: unexpected token `('
-bash: /etc/bash_completion.d/bzr: line 29: syntax error near `@($'
-bash: /etc/bash_completion.d/bzr: line 29: `	if [[ ${COMP_WORDS[1]} != @($helpCmds) ]] && \'

Expected results:
no syntax error expected.

Additional info:
This error message is not shown under EL6.

Comment 1 Toshio Ernie Kuratomi 2011-12-13 17:14:52 UTC
I'm unable to reproduce this:

$ rpm -q bash bzr bash-completion
bash-3.2-32.el5
bzr-2.1.4-1.el5
bash-completion-1.3-5.el5

$ source /etc/bash_completion.d/bzr

This is on an x86 host instead of an x86_64 host.  I don't see how that would affect things, though.

Comment 2 Kamae Norihiro 2011-12-13 19:19:14 UTC
I find that shopt extglob affects the error.
With shopt -s extglob, the error is not reproduced.
Though my tested hosts are Scientific Linux 5.6 x86_64 and CentOS 5.3 i686, both of them reproduces with shopt -u extglob.

Comment 3 Toshio Ernie Kuratomi 2011-12-13 22:53:10 UTC
Thanks.  Pushing a new package that I think will fix this.

Comment 4 Fedora Update System 2011-12-13 22:53:51 UTC
bzr-2.1.4-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bzr-2.1.4-2.el5

Comment 5 Kamae Norihiro 2011-12-14 03:25:27 UTC
The update fixed this problem. Thank you.

Comment 6 Fedora Update System 2011-12-14 20:28:21 UTC
Package bzr-2.1.4-2.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing bzr-2.1.4-2.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-5236/bzr-2.1.4-2.el5
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-12-29 22:00:36 UTC
bzr-2.1.4-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.