Bug 767173 - kernel 3.1.5-1 iwlagn with Intel 5300 WiFi fails to authenticate
kernel 3.1.5-1 iwlagn with Intel 5300 WiFi fails to authenticate
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
: 767472 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 08:39 EST by Roger Noble
Modified: 2012-01-05 04:03 EST (History)
10 users (show)

See Also:
Fixed In Version: kernel-3.1.5-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-17 15:52:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (1.79 KB, text/plain)
2011-12-13 08:39 EST, Roger Noble
no flags Details
log output (11.39 KB, text/plain)
2011-12-13 08:40 EST, Roger Noble
no flags Details
wpa_supplicant log output (610 bytes, text/plain)
2011-12-13 08:41 EST, Roger Noble
no flags Details

  None (edit)
Description Roger Noble 2011-12-13 08:39:58 EST
Created attachment 546203 [details]
dmesg output

Description of problem:

Kernel 3.1.5-1 iwlagn driver used with an Intel Ultimate N WiFi Link 5300 fails to authenticate with a WPA/WPA2 Personal access point. Reverting to kernel 3.1.4-1 fixes the problem.

Version-Release number of selected component (if applicable):

3.1.5-1

How reproducible:

Always.

Steps to Reproduce:

1. Try to connect to wireless router using Network Manager.
2. 
3.
  
Actual results:

Failure to connect.

Expected results:

Successful connection.

Additional info:

I've attached dmesg, log and wpa_supplicant.log output.
Comment 1 Roger Noble 2011-12-13 08:40:41 EST
Created attachment 546204 [details]
log output
Comment 2 Roger Noble 2011-12-13 08:41:21 EST
Created attachment 546205 [details]
wpa_supplicant log output
Comment 3 Josh Boyer 2011-12-13 08:51:25 EST
Seems there is some kind of regression in iwlagn with 3.1.5:

http://thread.gmane.org/gmane.linux.network/214856
Comment 4 Stanislaw Gruszka 2011-12-13 09:03:43 EST
Indeed, but I would rather expect commit causing breakage is:
> 5c30a5b33f77264cddcfb1a6659d3a9ac2661103 iwlagn: fix HW crypto for TX-only keys
not:
> 43c308bd8d0a3e7d98c5abcd41a4a3fada3d198f iwlwifi: do not re-configure HT40 after associated

Tomorrow I'll provide test kernels and we will see (or maybe intel will provide proper fix in that time :)
Comment 5 Stanislaw Gruszka 2011-12-14 11:51:30 EST
Roger, please check if one of these kernels make iwlwifi works in your setup:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3584255
http://koji.fedoraproject.org/koji/taskinfo?taskID=3584274
Comment 6 Eric Donkersloot 2011-12-14 15:49:20 EST
Same issue here, 3.1.4-1.fc16.x86_64 works fine.

02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
	Subsystem: Intel Corporation Centrino Advanced-N 6230 AGN
	Flags: bus master, fast devsel, latency 0, IRQ 49
	Memory at c7400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlagn
	Kernel modules: iwlagn
Comment 7 Roger Noble 2011-12-14 17:29:15 EST
(In reply to comment #5)
> Roger, please check if one of these kernels make iwlwifi works in your setup:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3584255
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3584274

Hi Stanislaw,

The ht40_fix kernel fixes the problem. The revert_hwcrypto one does not. Many thanks for the quick response.

Roger
Comment 8 Stanislaw Gruszka 2011-12-15 07:59:55 EST
Here is exact fix posted by Wey.
http://marc.info/?l=linux-wireless&m=132388345109047&w=2

Josh, please apply.
Comment 9 Josh Boyer 2011-12-15 09:40:34 EST
OK, will do.
Comment 10 Josh Boyer 2011-12-15 11:00:05 EST
Applied to f15/f16 (both are on 3.1.5).
Comment 11 Fedora Update System 2011-12-15 13:27:24 EST
kernel-3.1.5-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.5-6.fc16
Comment 12 Fedora Update System 2011-12-15 13:53:30 EST
kernel-2.6.41.5-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.5-4.fc15
Comment 13 Tore H. Larsen 2011-12-15 17:33:43 EST
cc
Comment 14 Josh Boyer 2011-12-15 17:41:28 EST
*** Bug 767472 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2011-12-16 14:57:50 EST
Package kernel-3.1.5-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.5-6.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17180/kernel-3.1.5-6.fc16
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-12-17 15:52:02 EST
kernel-3.1.5-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-12-21 20:17:10 EST
kernel-2.6.41.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.6-1.fc15

Note You need to log in before you can comment on or make changes to this bug.