Bug 767186 - Inform user about possible ways of configuration
Inform user about possible ways of configuration
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2011-12-13 09:10 EST by Petr Pisar
Modified: 2015-02-01 17:55 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:01:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2011-12-13 09:10:56 EST
As described in comment #7 of bug #636000, I expect that ABRT will not save any passwords or credentials if "Don't store passwords" is enabled in Bugzilla reporter settings. This is not true at this time (abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16).

How to reproduce:

(1) Double-click a not-submitted report.
(2) Press Forward button in Problem description.
(3) Tick on "I don't know what caused this problem", press Forward.
(4) Keep smolt profile unticked, press Apply.
(5) Select Bugzilla in Select reporter.
(6) Error message `Wrong settings in Buzilla' appears, press Configure
Bugzilla,
    fill in User name, keep password empty, tick Don't store passwords on,
    press Ok.
(7) Localized modal window grabbing keyboard and focus by Gnome key
    ring / pinentry appears requesting passphrase to key ring (it does not say
    it's Gnome key ring, but what else could it be?). I press Cancel.
(8) Error message "Error saving event 'report_Bugzilla' configuration to
    keyring" pops-up (with dummy `Unnamed window' title). The same message is
    printed into terminal. I dismiss the message by the only button Close.

This should not happen.

(9) Then the `Wrong settings in Buzilla' window from step (6) remains. I press
    Close.
(10) I press Forward in previous window (Select reporter from (5)).
(11) I press Forward in Review the data.
(12) I tick the review confirmation and press Apply.
(13) Next slide titled Reporting says Reporting finished with exit code 1.
     Lower Show log prints following error:

--- Running report_Bugzilla ---
Empty login or password, please check your configuration
(exited with 1)
Comment 1 Jakub Filak 2012-09-05 04:50:25 EDT
The "Don't store passwords" option causes that passwords are not stored in gnome-keyring but you have to fill in it otherwise bugzilla configuration is incomplete and it means wrong.
Comment 2 Jiri Moskovcak 2012-09-18 07:18:55 EDT
I think the label "Don't store password" is pretty clear and it's not saying that it won't save any credentials - the URL and your login name is not considered sensitive, so I don't see a reason why someone would like to not save it. Most users want to save the login name, so this use-case seems so special that it's not worth implementing. You can always delete the credentials from kwallet/gnome-keyring.
Comment 3 Petr Pisar 2012-09-18 07:35:59 EDT
What about remembering yet another password for kwallet/gnome-keyring just only to store abrt configuration? Isn't it silly?
Comment 4 Jakub Filak 2012-09-19 04:48:32 EDT
We met together with Petr and we found out that the problem is in the ABRT documentation. As I understand, Petr doesn't want to use gnome-keyring at all and he don't know that it is possible to configure required credentials in configuration files.

Conclusion:
Inform user about possible ways of configuration.
Comment 5 Jakub Filak 2012-09-19 04:49:01 EDT
commit 43ac450576e502fd88707ffde9e4a4937cf1dcd2
Author: Jakub Filak <jfilak@redhat.com>
Date:   Tue Sep 18 16:33:04 2012 +0200

    rhbz#767186: show a link to a page describing the ABRT configuration
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 6 Fedora Update System 2012-09-24 10:31:50 EDT
abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
Comment 7 Fedora Update System 2012-09-24 16:03:54 EDT
Package abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.13-1.fc18 libreport-2.0.14-1.fc18 btparser-0.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14679/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-09-25 06:06:20 EDT
abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17
Comment 9 Fedora Update System 2012-12-20 11:01:22 EST
abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.